Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 6014

Summary: Upgrade scripts handles errors poorly
Product: [Retired] Red Hat Linux Reporter: alanrb
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-21 16:23:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description alanrb 1999-10-17 02:21:46 UTC
While upgrading from 6.0 to 6.1 via FTP I had several errors
that the installer did not handle very well. It apparently
just crashed the script and displayed a traceback. It took
me awhile before I figured out how to deal with this.
Clicking OK or DEBUG just seemed to eventually get me to a
hung system. Scrolling the traceback and trying to interpret
the messages eventually allowed me to get past the problems,
which I have listed below:

* /etc/lilo.conf was linked to /boot/lilo.conf on my 6.0
system, but that is not valid with the installs mounting
setup, so no writtable file existed. The lack of checking on
this may be related to the other problems with lilo.conf
that have been reported.

* Upgrade was done via FTP; transmission errors and login
failure due to exceeding user limits lead to script crash
and the traceback.

This may be tough to deal with, but I think a complete
novice user would be stuck if they hit these.

Comment 1 Jay Turner 1999-10-21 16:23:59 UTC
*** This bug has been marked as a duplicate of 5788 ***