Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 60

Summary: in.rexecd doesn't work with PAM securetty authentication
Product: [Retired] Red Hat Linux Reporter: dudek
Component: rshAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0CC: dudek
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-26 23:49:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description dudek 1998-11-12 18:53:42 UTC
As shipped, in.rexecd is disabled in /etc/inetd.conf.  If
you enable it, rexec will still not work because
/etc/pam.d/rexec tries to authenticate using securetty PAM
authentication (as it should), but in.rexecd does not set
the PAM_TTY item.  I believe this bug exists in RedHat 5.2
as well.  The fix is to add a call to:

(void) pam_set_item (pamh, PAM_TTY, "tty");

just before calling pam_authenticate.

Comment 1 Jeff Johnson 1999-03-26 23:49:59 UTC
Should be fixed in rsh-0.10-23.