Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5998

Summary: squashing doesn't work
Product: [Retired] Red Hat Linux Reporter: Craig Kelley <namonai>
Component: nfs-serverAssignee: Cristian Gafton <gafton>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.1CC: dkl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-17 12:03:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Craig Kelley 1999-10-15 21:14:39 UTC
I have RedHat 6.1 with:

  knfsd-clients-1.4.7-7
  knfsd-1.4.7-7

My export file looks like this:

  /usr/local/pub private.isu.edu(ro,squash_all)

The target machine still gets all the UIDs and only the
root-owned files get squashed to nobody.  The nobody IDs are
the same on both machines (the target machine is RedHat
5.2).  This makes it next to impossible to have public
exports based on real user's work.

Comment 1 Bernhard Rosenkraenzer 2000-02-17 12:03:59 UTC
It's all_squash, not squash_all.