Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 598847

Summary: `gpg2 -h` does not work in FIPS mode
Product: Red Hat Enterprise Linux 6 Reporter: Jan Hutař <jhutar>
Component: gnupg2Assignee: Tomas Mraz <tmraz>
Status: CLOSED CURRENTRELEASE QA Contact: Ondrej Moriš <omoris>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: omoris, sgrubb
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: gnupg2-2.0.14-3.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-10 20:34:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jan Hutař 2010-06-02 07:48:43 UTC
Description of problem:
I'm not able to get help message for gpg2 when on system in FIPS mode.


Version-Release number of selected component (if applicable):
gnupg2-2.0.14-2.el6.i686


How reproducible:
always


Steps to Reproduce:
1. # gpg2 --help


Actual results:
# gpg2 -h
gpg (GnuPG) 2.0.14
libgcrypt 1.4.5
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Home: ~/.gnupg
Supported algorithms:
Ohhhh jeeee: secure memory is disabledfatal error in libgcrypt, file misc.c, line 137, function _gcry_logv: internal error (fatal or bug)
Aborted
# echo $?
134


Expected results:
This should display help message.

Comment 1 RHEL Product and Program Management 2010-06-02 08:06:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Tomas Mraz 2010-06-21 14:32:19 UTC
Fixed. Note that due to libgcrypt requiring initialization of the FIPS random number generator in the FIPS mode before any other call to the crypto library it will block on virtual machines or other machines with low entropy source. I suggest mount --bind /dev/urandom /dev/random as temporary workaround on the test machines.

Comment 4 Ondrej Moriš 2010-09-06 10:07:00 UTC
Successfully verified.

Old (gnupg2-2.0.14-2.el6)
=========================

# gpg2 -h
gpg (GnuPG) 2.0.14
libgcrypt 1.4.5
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Home: ~/.gnupg
Supported algorithms:
Ohhhh jeeee: secure memory is disabledfatal error in libgcrypt, file misc.c, line 137, function _gcry_logv: internal error (fatal or bug)
Aborted (core dumped)

# gpg2 --help
gpg (GnuPG) 2.0.14
libgcrypt 1.4.5
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Home: ~/.gnupg
Supported algorithms:
Ohhhh jeeee: secure memory is disabledfatal error in libgcrypt, file misc.c, line 137, function _gcry_logv: internal error (fatal or bug)
Aborted (core dumped)

New (gnupg2-2.0.14-3.el6)
=========================

# gpg2 --help
gpg (GnuPG) 2.0.14
libgcrypt 1.4.5
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Home: ~/.gnupg
Supported algorithms:
Pubkey: RSA, ELG, DSA
Cipher: 3DES, AES, AES192, AES256
Hash: MD5, SHA1, SHA256, SHA384, SHA512, SHA224
Compression: Uncompressed, ZIP, ZLIB, BZIP2

Syntax: gpg [options] [files]
sign, check, encrypt or decrypt
default operation depends on the input data

Commands:
...

# gpg2 -h
gpg (GnuPG) 2.0.14
libgcrypt 1.4.5
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Home: ~/.gnupg
Supported algorithms:
Pubkey: RSA, ELG, DSA
Cipher: 3DES, AES, AES192, AES256
Hash: MD5, SHA1, SHA256, SHA384, SHA512, SHA224
Compression: Uncompressed, ZIP, ZLIB, BZIP2

Syntax: gpg [options] [files]
sign, check, encrypt or decrypt
default operation depends on the input data

Commands:
...

Comment 5 releng-rhel@redhat.com 2010-11-10 20:34:56 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.