Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 598590

Summary: [abrt] crash in system-config-printer-1.2.1-1.fc13: system-config-printer.py:6242:fillModelList:AttributeError: 'NoneType' object has no attribute 'lower'
Product: [Fedora] Fedora Reporter: ramzi <ramzi986>
Component: system-config-printerAssignee: Tim Waugh <twaugh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: jpopelka, twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard: abrt_hash:6e4bdf96
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-02 11:46:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace none

Description ramzi 2010-06-01 17:01:03 UTC
abrt 1.1.0 detected a crash.

architecture: i686
cmdline: python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.33.3-85.fc13.i686.PAE
package: system-config-printer-1.2.1-1.fc13
reason: system-config-printer.py:6242:fillModelList:AttributeError: 'NoneType' object has no attribute 'lower'
release: Fedora release 13 (Goddard)

backtrace
-----
system-config-printer.py:6242:fillModelList:AttributeError: 'NoneType' object has no attribute 'lower'

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 6235, in on_tvNPMakes_cursor_changed
    self.fillModelList()
  File "/usr/share/system-config-printer/system-config-printer.py", line 6242, in fillModelList
    is_auto_make = self.NPMake.lower () == self.auto_make.lower ()
AttributeError: 'NoneType' object has no attribute 'lower'

Local variables in innermost frame:
models: [u'ESC/P Dot Matrix Printer', u'GDI Printer', u'IBM-Compatible Dot Matrix Printer', u'PCL 3 Printer', u'PCL 4 LF Printer', u'PCL 4 Printer', u'PCL 5 LF Printer', u'PCL 5 Printer', u'PCL 5c LF Printer', u'PCL 5c Printer', u'PCL 5e LF Printer', u'PCL 5e Printer', u'PCL 6/PCL XL LF Printer', u'PCL 6/PCL XL Printer', u'PCL Laser Printer', u'PostScript Level 1 Printer', u'PostScript Printer', u'Raw Queue', u'text-only printer']
model: <gtk.ListStore object at 0x9f8eaa4 (GtkListStore at 0x9be4550)>
selected: False
self: <__main__.NewPrinterGUI instance at 0x9a1a24c>

Comment 1 ramzi 2010-06-01 17:01:06 UTC
Created attachment 418735 [details]
File: backtrace

Comment 2 Jiri Popelka 2010-06-02 11:46:58 UTC

*** This bug has been marked as a duplicate of bug 590193 ***