Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 598413

Summary: [ALL] few untranslated strings in all languages
Product: Red Hat Enterprise Linux 6 Reporter: A S Alam <aalam>
Component: anacondaAssignee: Ales Kozumplik <akozumpl>
Status: CLOSED CURRENTRELEASE QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: low    
Version: 6.1CC: borgan, eng-i18n-bugs, jzeleny, mshao
Target Milestone: rcKeywords: i18n
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: anaconda-13.21.51-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-11-10 19:46:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 599608    
Bug Blocks:    
Attachments:
Description Flags
Disk partition Untranslated
none
Package selection
none
Package Number
none
Time Zone
none
RAID information - one untranslated string
none
Advance Storage Screen
none
screenshot of "Examining Disk" none

Description A S Alam 2010-06-01 11:14:11 UTC
Created attachment 418583 [details]
Disk partition Untranslated

Description of problem:
while upstream translation [1] seems completed (100%), still anaconda has few un-translated messaged (providing screenshots).

Version-Release number of selected component (if applicable):
anaconda-13.21.48-1.el6

How reproducible:
everytime

Steps to Reproduce:
1. run anaconda, 
2.
3.
  
Actual results:
Few strings are in English

Expected results:
should be in POT file or translate-able 

Additional info:

[1] https://translate.fedoraproject.org/projects/p/anaconda/c/rhel6-branch/

Comment 1 A S Alam 2010-06-01 11:14:40 UTC
Created attachment 418584 [details]
Package selection

Comment 2 A S Alam 2010-06-01 11:15:03 UTC
Created attachment 418585 [details]
Package Number

Comment 4 A S Alam 2010-06-01 11:25:48 UTC
Created attachment 418589 [details]
RAID information - one untranslated string

Comment 6 Chris Lumens 2010-06-01 16:53:53 UTC
Looks like these are all C_ strings and the second branch of P_ strings not making it into anaconda.pot.

Reference for C_:  http://library.gnome.org/devel/glib/unstable/glib-I18N.html#C-:CAPS

Comment 7 RHEL Product and Program Management 2010-06-01 16:55:53 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 8 A S Alam 2010-06-02 05:03:55 UTC
Created attachment 418907 [details]
Advance Storage Screen

Another missing string

Comment 9 Ales Kozumplik 2010-06-04 11:38:19 UTC
Patches for severa translation issues sent to a-d-list:
https://www.redhat.com/archives/anaconda-devel-list/2010-June/msg00087.html

There is still at least one more known translation problem at the moment: stock gtk buttons like '_Cancel' are not translated. This is due to the weird ways gettext is treated in newt-python (snack) and described in bug 599608.

Comment 10 Ales Kozumplik 2010-06-10 14:58:30 UTC
The bulk of the problems (timezones, advanced storage devices dialog, repos screen) should be fixed in anaconda-31.21.51-1.el6. We'll have to give the translators some time to translate the plural forms that were missing in anaconda.pot until now.

directly related rhel6 commits are:
b44e60d1f81d5113bac6d874907f5d37e836ad8f
d632a28bd7e074865829b5cee81d2b93c1e289e6
74f87f2bcc219ece628333166bc44a954e7c24cc
06358be1137cdf45507df2773cd5972821ae148d

Comment 11 A S Alam 2010-06-17 03:45:31 UTC
most of strings are translated. Few missing as in screenshot comment #1, #2 and #4 with new one. 
Moving to Assign:

Comment 12 A S Alam 2010-06-17 03:46:33 UTC
Created attachment 424659 [details]
screenshot of "Examining Disk"

Comment 13 Ales Kozumplik 2010-06-17 06:24:16 UTC
A.S,

what language do you see the missing strings in?

Ales

Comment 15 Ales Kozumplik 2010-06-18 09:16:30 UTC
One by one (I'm only trying Japanese):

1) package number: While the pot file now correctly has a singular and a plural form, the translation is still missing in the Japanese .po file. We just have to wait for new translations.

2) "The default installation..." string. Yeah, this is an unfortunate coincidence, I've opened bug 605556 for this.

3) "Examining disk". This is present in the .pot file but missing from the Japanese .po. Again, we have to wait.

I suggest we go on with QAing this BZ and even close it and take the issue #2 separately (it involves rel-eng too).

Ales

Comment 16 A S Alam 2010-06-22 04:38:34 UTC
Verified: (with help of Comment #15 and following)
1) Confirmed, it is in pot, translation Need to update->Translation Bug #527925
2) Bug #605556
3) i18n issue Fixed, now track in Translation bug #527925

Comment 17 releng-rhel@redhat.com 2010-11-10 19:46:28 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.