Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 598353

Summary: Browser plugin tends to rewrite ? to _ in URLs, causing 404 errors
Product: [Fedora] Fedora Reporter: Tore Anderson <tore>
Component: java-1.6.0-openjdkAssignee: Deepak Bhole <dbhole>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: dbhole, langel, lkundrak, mjw, mmatejov, omajid, robatino
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: java-1.6.0-openjdk-1.6.0.0-39.b18.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-21 13:03:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tore Anderson 2010-06-01 07:21:09 UTC
Description of problem:

I've noticed that some web sites that are redirecting the browser based on a Java applet or something like that, will rewrite to a URL that has «_» instead of «?».  This causes the web page to fail.  I'm assuming this is a bug in the plugin/JDK itself since I've seen the same thing happen on two completely independent web sites.

Version-Release number of selected component (if applicable):

F13, java-1.6.0-openjdk-plugin-1.6.0.0-37.b17.fc13.x86_64, firefox-3.6.3-4.fc13.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Go to <http://www.java.com/en/download/installed.jsp>
2. Press the button «Verify Java version»

Actual results:

The browser gets redirected to <http://www.java.com/en/download/installed.jsp_jre_version=1.6.0_17&vendor=Sun+Microsystems+Inc.&os=Linux&os_version=2.6.33.4-95.fc13.x86_64>

Expected results:

The browser should have been redirected to <http://www.java.com/en/download/installed.jsp?jre_version=1.6.0_17&vendor=Sun+Microsystems+Inc.&os=Linux&os_version=2.6.33.4-95.fc13.x86_64>.

Additional info:

Comment 1 Omair Majid 2010-06-14 20:17:01 UTC
Fixed upstream:

http://icedtea.classpath.org/hg/icedtea6/rev/3dc9772300a0

Comment 2 Fedora Update System 2010-06-15 09:23:31 UTC
java-1.6.0-openjdk-1.6.0.0-41.b18.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-41.b18.fc13

Comment 3 Fedora Update System 2010-06-15 16:03:34 UTC
java-1.6.0-openjdk-1.6.0.0-41.b18.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2010-06-16 12:36:42 UTC
java-1.6.0-openjdk-1.6.0.0-39.b18.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-39.b18.fc12

Comment 5 Andre Robatino 2010-06-16 13:46:23 UTC
This still affects the current F12 version (but not the test version in comment 4!) so this could be reopened with the Version changed to 12 (although hopefully the test version will be pushed to stable soon, at which point it won't matter).

Comment 6 Tore Anderson 2010-06-16 14:53:07 UTC
Sure thing, Andre.

Tore

Comment 7 Fedora Update System 2010-06-17 19:23:49 UTC
java-1.6.0-openjdk-1.6.0.0-36.b18.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-36.b18.fc11

Comment 8 Fedora Update System 2010-06-21 13:03:31 UTC
java-1.6.0-openjdk-1.6.0.0-36.b18.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-06-21 13:08:23 UTC
java-1.6.0-openjdk-1.6.0.0-39.b18.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.