Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 598178

Summary: [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib64/firefox-3.5/firefox was killed by signal 6 (SIGABRT)
Product: [Fedora] Fedora Reporter: Dante <dandreadante>
Component: firefoxAssignee: Gecko Maintainer <gecko-bugs-nobody>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: campbecg, gecko-bugs-nobody
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: abrt_hash:e38322603332616ac8462756fa8172138e0e19bc
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-12 22:57:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace none

Description Dante 2010-05-31 16:49:30 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.5/firefox
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/firefox-3.5/firefox
global_uuid: e38322603332616ac8462756fa8172138e0e19bc
kernel: 2.6.32.12-115.fc12.x86_64
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib64/firefox-3.5/firefox was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

Comment 1 Dante 2010-05-31 16:49:44 UTC
Created attachment 418340 [details]
File: backtrace

Comment 2 Chris Campbell 2010-06-12 22:53:57 UTC
#5  0x00000030264ba2cd in __gnu_cxx::__verbose_terminate_handler ()
    at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
        terminating = true
        t = <value optimized out>
#6  0x00000030264b8456 in __cxxabiv1::__terminate (
    handler=<value optimized out>)
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:38
No locals.
#7  0x00000030264b8483 in std::terminate ()
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:48
No locals.
#8  0x00000030264b8daf in __cxxabiv1::__cxa_pure_virtual ()
    at ../../../../libstdc++-v3/libsupc++/pure.cc:50
No locals.
#9  0x000000302e8950b2 in nsCOMPtr_base::assign_from_qi (this=0x7ffffd55d510, 
    qi=..., iid=...) at nsCOMPtr.cpp:96
        newRawPtr = 0x2db
#10 0x000000302e07fc44 in nsCOMPtr (this=<value optimized out>, 
    aJSContext=0x6, aOldScope=0x7fa4a2c39a40, aNewScope=<value optimized out>)
    at ../../../../dist/include/xpcom/nsCOMPtr.h:572
No locals.
#11 nsXPConnect::ReparentScopeAwareWrappers (this=<value optimized out>, 
    aJSContext=0x6, aOldScope=0x7fa4a2c39a40, aNewScope=<value optimized out>)
    at nsXPConnect.cpp:1465
        identity = 0x7fa4a206da60
        info = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        sciWrapper = {mCallback = {<nsCOMPtr_base> = {
              mRawPtr = 0x7fa4b5e1f3e0}, <No data fields>}, mFlags = {
            mFlags = 200151717}}
        rv = <value optimized out>
        junk = {mRawPtr = 0x0}
        sciProto = {mCallback = {<nsCOMPtr_base> = {
              mRawPtr = 0x7fa4b5e1f3e0}, <No data fields>}, mFlags = {
            mFlags = 200151717}}
        newParent = 0x7fa4a2c39a40
        i = 732
        stop = <value optimized out>
        ccx = {<nsAXPCNativeCallContext> = {
            _vptr.nsAXPCNativeCallContext = 0x302f00ff30}, 
          mState = HAVE_CONTEXT, mXPC = 0x7fa4ba7cf110, 
          mThreadData = 0x7fa4b8a4be20, mXPCContext = 0x7fa4a8e3f600, 
          mJSContext = 0x7fa4a8bca400, mContextPopRequired = 0, 
          mDestroyJSContextInDestructor = 0, mCallerLanguage = LANG_NATIVE, 
          mPrevCallerLanguage = LANG_JS, mPrevCallContext = 0x7ffffd55e070, 
          mOperandJSObject = 0x7fa4c1d6c4b0, mCurrentJSObject = 0x4, 
          mFlattenedJSObject = 0x0, mWrapper = 0x0, mTearOff = 0x302e40aba6, 
          mScriptableInfo = 0x302f186698, mSet = 0x7fa49bc3b368, 
          mInterface = 0x4, mMember = 0x302e40aba6, mName = 140344998168576, 
          mStaticMemberIsLocal = -44705600, mArgc = 32767, 
          mArgv = 0x301e4110bd, mRetVal = 0x7fa4c1bff000, 
          mReturnValueWasSet = 780989237, mMethodIndex = 48, mCallee = 0x0, 
          mStringWrapperData = "\320\fZ\237\244\177\000\000n\271&.0\000\000\000\000\000\000\000\244\177\000\000\210\326U\375\377\177\000\000\200\062\322\235\244\177\000\000\000\000\000\000\060\000\000"}
        oldScope = 0x7fa49dee9b00
        newScope = <value optimized out>
        wrappersToMove = {mImpl = 0x7fa4a5ffc000}



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-06-12 22:57:29 UTC
Thank you for taking the time to make this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 546155 ***