Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 597593

Summary: Cannot Modify Existing
Product: [Fedora] Fedora Reporter: Jayesh Badwaik <jayeshb.work>
Component: system-config-lvmAssignee: Marek Grac <mgrac>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: low    
Version: 13CC: agk, dwysocha, itamar, jayeshb.work, mbroz, mclasen, mgrac, prockai, stsp2
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: system-config-lvm-1.1.14-2.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-14 15:54:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
This is the actual screen of the error message.
none
Proposed patch none

Description Jayesh Badwaik 2010-05-29 18:03:17 UTC
Description of problem:
I am not able to modify(resize, enable mount point) for all my Logical Volumes. Refer to the picture, it shows the volume as unmounted while it is currently mounted at /home according to df -h command. Also, I am not able to assign the mount point to the LV, it is not preassigned as it should be.  Error takes place even when i don't actually edit the LV but just click on 'Edit Properties' and then click OK.

Version-Release number of selected component (if applicable):
1.1.13

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora 13 using x86_64 DVD and LVM 
2. Install system-config-lvm package using yum
3. Try to modify a LV
  
Actual results:
Error Message

Expected results:
No Error Message

Additional info:
During Fedora 13 installation, i have unchecked the GNOME Desktop Environment and instead installed only the KDE environment. Haven't checked with GNOME Desktop Environment. However, I hope any dependency should be taken care of using yum?

Comment 1 Marek Grac 2010-05-31 12:18:31 UTC
Can you give me that error message?

Comment 2 Jayesh Badwaik 2010-05-31 17:22:39 UTC
The exact error message is 
"Logical volume is not mounted but is in use. Please close all applications using this device (eg iscsi)".

I have verified the bug with GNOME too. Command Line Tool (lvm) works fine.

Comment 3 Jayesh Badwaik 2010-05-31 17:24:10 UTC
Created attachment 418353 [details]
This is the actual screen of the error message.

Comment 4 Marek Grac 2010-06-01 14:29:47 UTC
Created attachment 418656 [details]
Proposed patch

Hi,

if it is possible please try to apply this patch. It works for me on my testing F13 box. If it will work I will apply it upstream

thanks

Comment 5 Jayesh Badwaik 2010-06-01 16:06:32 UTC
i don't have a box to experiment right now but i'll try to apply the patch and tell you the result........

thanks

Comment 6 Jayesh Badwaik 2010-06-10 17:43:08 UTC
i have verified the patch it works well without any error message...

Comment 7 Marek Grac 2010-06-11 11:36:13 UTC
Thanks, I will release new version soon

Comment 8 Marek Grac 2010-06-11 15:44:16 UTC
*** Bug 603112 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2010-06-16 12:16:40 UTC
system-config-lvm-1.1.14-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-lvm-1.1.14-2.fc13

Comment 11 Fedora Update System 2010-06-22 17:16:59 UTC
system-config-lvm-1.1.14-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.