Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5971

Summary: Filenames with spaces are truncated by uudecode
Product: [Retired] Red Hat Linux Reporter: aldennis
Component: sharutilsAssignee: Preston Brown <pbrown>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 5.2CC: aldennis
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-21 16:55:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description aldennis 1999-10-15 01:54:30 UTC
uuencode file "file with spaces" | uudecode
results in uudecode not creating the file "file with spaces"
but instead creating (overwriting in this example) "file".

I'll send my patch as soon as this annoying Bugzilla thing
gives me a Bug ID.

Comment 1 Bill Nottingham 1999-10-15 15:36:59 UTC
*** Bug 5972 has been marked as a duplicate of this bug. ***

uuencode file "file with spaces" | uudecode
results in uudecode not creating the file "file with spaces"
but instead creating (overwriting in this example) "file".

I'll send my patch as soon as this annoying Bugzilla thing
gives me a Bug ID.

Comment 2 Preston Brown 1999-12-21 16:55:59 UTC
fixed in a forthcoming errata release (v. 4.2.1).