Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5964

Summary: Installer makes hostname alias for localhost
Product: [Retired] Red Hat Linux Reporter: Nalin Dahyabhai <nalin.dahyabhai>
Component: installerAssignee: Erik Troan <ewt>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-23 19:25:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nalin Dahyabhai 1999-10-14 20:44:47 UTC
In todo.py (line 1003), anaconda takes the hostname that's
been looked up by resolving the address assigned by dhcp
(line 128), and makes it an alias for localhost.localdomain,
which makes sendmail rewrite outgoing mail headers to be
from <user@localhost.localdomain>, which is bad.
It probably breaks various other things as well.

Comment 1 Jay Turner 1999-10-21 18:34:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Nalin Dahyabhai 2000-01-07 17:40:59 UTC
*** Bug 5967 has been marked as a duplicate of this bug. ***

Comment 3 Erik Troan 2000-02-23 19:25:59 UTC
Fixed internally.