Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5951

Summary: 6.1 upgrade overwrote MBR without asking
Product: [Retired] Red Hat Linux Reporter: ryan_gustafson
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-22 16:32:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description ryan_gustafson 1999-10-14 15:59:17 UTC
I had a 6.0 install on my system.  I was using System
Commander (a commercial product) to handle loading the
multiple OS's I run (Linux, 98, NT).

I recently tried upgrading to 6.1.  First time thru the
install, I figured I'd try doing an "upgrade" (I normally
do complete re-installs).  I followed the graphical
installer instructions, and 6.1 was installed/upgraded.
When the system rebooted I found that LILO was setup on
my MBR, not on my Linux Partition (as I had been using).

Not exactly what I was expecting.  During an upgrade, why
setup LILO on a partition where it does _not_ exist? I can
see on a new install (and the installer explicitly asks in
that case), but during an upgrade, presumably one does not
change the location of the existing boot loader.  The
installer should _not_ _assume_ the location of the boot
loader.  It should make a best effort to determine where to
install, and then ask if that is what I want.

Anyway, some more data points...

LILO had a 'dos' entry available, so I tried it out.  That
got me into Win98 (not System Commander, and
co-incidentally the OS I booted before my upgrade attempt).
Curious thing though, when I rebooted after that System
Commander came up (and has since).  I presume System
Commander "reinstalled" itself in the MBR somehow.

BTW, I things are really great otherwise, it even detected
my SB!Live card.  Although I don't think it works under SMP
kernels yet, perhaps I try just to see, I'd be pleasantly
surprised if it did work.

Comment 1 Jay Turner 1999-10-21 18:24:59 UTC
*** This bug has been marked as a duplicate of 5576 ***

Comment 2 Bill Nottingham 1999-10-22 16:32:59 UTC
*** This bug has been marked as a duplicate of 5798 ***