Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5948

Summary: by upgrading from 6.o to 6.1 the install program can't find the linux partition
Product: [Retired] Red Hat Linux Reporter: giancarlo.dilisi
Component: redhat-releaseAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 6.1CC: bammi, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-26 21:04:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description giancarlo.dilisi 1999-10-14 11:42:48 UTC
The install programm abort by upgrading from 6.0 to 6.1.
It report: can't find linux partition...

Hardware: Compaq Armada 1750 Laptop with W2000beta3 and
Redhat 6.0.

####################################################
partition table:

Disk /dev/hda: 240 heads, 63 sectors, 839 cylinders
Units = cylinders of 15120 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1         2     15088+  12  Compaq
diagnostics
/dev/hda2   *         3         5     22680    4  FAT16 <32M
/dev/hda3             6       839   6305040    f  Win95
Ext'd (LBA)
/dev/hda5             6       276   2048728+   7  HPFS/NTFS
/dev/hda6           277       547   2048728+   7  HPFS/NTFS
/dev/hda7           548       574    204088+  82  Linux swap
/dev/hda8           575       839   2003368+  83  Linux

############################################################

the testit program from the Redhat 6.1 CD
(/misc/src/anaconda/balkan) display the follow:

i: 0 (3, 63, 30177)
i: 1 (1, 30240, 45360)
i: 2 (1, 75600, 12610080)

##########################################################

happy fixing

Comment 1 bammi 1999-10-22 16:54:59 UTC
I have the same problem on a Toshiba system. My partition map is
similar:
/hda1  NTFS
hda5    VFAT
hda6  ext2  and contains /
hda6-12 ext with other mount points
had11 is swap

the installer crashes with
error: mounting ext 2 filesystem on hda1: Invalid arg

I am trying to use the upgrade path for RH 6.1

RH 6.0 is happyly running in the above setup

Any way to convince the installer to look in /hda6 for previous Linux?

I tried the new boot images with "linux updates" and "linux updates
text" with no difference.

Thanks

Comment 2 David Lawrence 1999-10-26 21:04:59 UTC
The problem is with the installer not recognizing the Win98 extended
partition type properly. This should be fixed in the latest errata
(yes the boot images have yet changed again) boot images available at
http://www.redhat.com/support.

If this doesnt fix your problem please reopen this report.