Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 593473

Summary: SELinux is preventing /usr/bin/who "read" access on /etc/nsswitch.conf.
Product: [Fedora] Fedora Reporter: Brian Whitehead <bwhitehd>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:009bc133cc142c1c0c8d9b904039ce4e110336006e688a3d083f5eb4fa0bf62a
Fixed In Version: selinux-policy-3.6.32-116.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-04 18:58:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Brian Whitehead 2010-05-18 21:24:54 UTC
Summary:

SELinux is preventing /usr/bin/who "read" access on /etc/nsswitch.conf.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by who. It is not expected that this access is
required by who and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:munin_system_plugin_t:s0
Target Context                system_u:object_r:etc_t:s0
Target Objects                /etc/nsswitch.conf [ file ]
Source                        uptime
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-7.6-11.fc12
Target RPM Packages           glibc-2.11.1-6
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   130
First Seen                    Tue 18 May 2010 01:18:20 PM CDT
Last Seen                     Tue 18 May 2010 04:20:09 PM CDT
Local ID                      41460b55-1495-4760-b951-b7fbbe55b6d1
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274217609.172:3306): avc:  denied  { read } for  pid=16865 comm="who" name="nsswitch.conf" dev=dm-0 ino=61041 scontext=system_u:system_r:munin_system_plugin_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1274217609.172:3306): avc:  denied  { open } for  pid=16865 comm="who" name="nsswitch.conf" dev=dm-0 ino=61041 scontext=system_u:system_r:munin_system_plugin_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274217609.172:3306): arch=c000003e syscall=2 success=yes exit=68719476864 a0=3331b3ced7 a1=0 a2=1b6 a3=2 items=0 ppid=16864 pid=16865 auid=4294967295 uid=485 gid=468 euid=485 suid=485 fsuid=485 egid=468 sgid=468 fsgid=468 tty=(none) ses=4294967295 comm="who" exe="/usr/bin/who" subj=system_u:system_r:munin_system_plugin_t:s0 key=(null)



Hash String generated from  catchall,uptime,munin_system_plugin_t,etc_t,file,read
audit2allow suggests:
audit2allow is not installed.

Comment 1 Daniel Walsh 2010-05-19 12:59:48 UTC
*** Bug 593477 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-05-19 14:00:03 UTC
Added to selinux-policy-3.6.32-115.fc12. The policy is available from koji for now

http://koji.fedoraproject.org/koji/buildinfo?buildID=173018

Comment 3 Fedora Update System 2010-05-21 13:52:38 UTC
selinux-policy-3.6.32-116.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-116.fc12

Comment 4 Fedora Update System 2010-05-24 19:34:41 UTC
selinux-policy-3.6.32-116.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-116.fc12

Comment 5 Fedora Update System 2010-06-04 18:57:29 UTC
selinux-policy-3.6.32-116.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.