Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 593427

Summary: SELinux is preventing /usr/libexec/fprintd "search" access on /usr/share.
Product: [Fedora] Fedora Reporter: Brian Whitehead <bwhitehd>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: dwalsh, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:3bca73d60a1a34e4c032a64e8a04c5c1d7950550eb9f6364c80a174370be9087
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-18 19:26:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Brian Whitehead 2010-05-18 18:54:49 UTC
Summary:

SELinux is preventing /usr/libexec/fprintd "search" access on /usr/share.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by fprintd. It is not expected that this access
is required by fprintd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:fprintd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:home_root_t:s0
Target Objects                /usr/share [ dir ]
Source                        fprintd
Source Path                   /usr/libexec/fprintd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           fprintd-0.1-16.git04fd09cfa.fc12
Target RPM Packages           filesystem-2.4.30-2.fc12
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Alert Count                   4
First Seen                    Tue 18 May 2010 01:18:41 PM CDT
Last Seen                     Tue 18 May 2010 01:18:41 PM CDT
Local ID                      f2e622d3-de71-48e5-8f4e-57e48f013b96
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274206721.992:67): avc:  denied  { search } for  pid=2699 comm="fprintd" name="share" dev=dm-0 ino=8198 scontext=system_u:system_r:fprintd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:home_root_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1274206721.992:67): avc:  denied  { search } for  pid=2699 comm="fprintd" name="locale" dev=dm-0 ino=16399 scontext=system_u:system_r:fprintd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1274206721.992:67): avc:  denied  { read } for  pid=2699 comm="fprintd" name="locale.alias" dev=dm-0 ino=92187 scontext=system_u:system_r:fprintd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1274206721.992:67): avc:  denied  { open } for  pid=2699 comm="fprintd" name="locale.alias" dev=dm-0 ino=92187 scontext=system_u:system_r:fprintd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274206721.992:67): arch=c000003e syscall=2 success=yes exit=3 a0=3333ecb858 a1=0 a2=1b6 a3=0 items=0 ppid=2698 pid=2699 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="fprintd" exe="/usr/libexec/fprintd" subj=system_u:system_r:fprintd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,fprintd,fprintd_t,home_root_t,dir,search
audit2allow suggests:
audit2allow is not installed.

Comment 1 Daniel Walsh 2010-05-18 19:26:04 UTC

*** This bug has been marked as a duplicate of bug 593420 ***