Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 593396

Summary: invalid fastbin entry (free)
Product: Red Hat Enterprise Linux 6 Reporter: Gordon Sim <gsim>
Component: glibcAssignee: Andreas Schwab <schwab>
Status: CLOSED CURRENTRELEASE QA Contact: Petr Muller <pmuller>
Severity: urgent Docs Contact:
Priority: high    
Version: 6.0CC: drepper, ebachalo, fweimer, iboverma, jneedle, kim.vdriet, ohudlick, pmuller, snagar
Target Milestone: beta   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: glibc-2.12-1.2.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 642329 (view as bug list) Environment:
Last Closed: 2010-07-02 19:09:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 589706    
Attachments:
Description Flags
test case
none
A smaller test case none

Description Gordon Sim 2010-05-18 17:57:14 UTC
Created attachment 414918 [details]
test case

Description of problem:

Seeing 'invalid fastbin entry (free)' errors for a test program that appears to have no bug in it that would legitimately cause such an error. Suspect this may be a bug in the fastbin verification logic.

Version-Release number of selected component (if applicable):

glibc-2.12-1.1.el6.x86_64

How reproducible:

Easily

Steps to Reproduce:
1. compile and run attached test case
  
Actual results:

Get a crash due to an invalid fastbin within a minute.

Expected results:

No crash.

Additional info:

Comment 1 Gordon Sim 2010-05-18 17:59:01 UTC
Created attachment 414920 [details]
A smaller test case

This requires use of the -std=c++0x option when compiling but cuts out some of the noise in the test case by replacing the trivial pthread wrapper classes in the previous attachement. Exhibits the same symptoms.

Comment 3 Jeff Needle 2010-05-18 18:41:31 UTC
This is a test blocker for us because it causes significant instability in the messaging broker on RHEL6.

Comment 5 Ulrich Drepper 2010-05-18 21:20:12 UTC
Before anything else is tried, this patch should be added to the RHEL6 glibc and then all tests repeated:

http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=5f24d53acb2cd02ffb4ac925c0244e4f1f854499;hp=d84acf388ed8b3f162dda0512139095bfc268beb

Comment 11 Andreas Schwab 2010-06-24 14:41:21 UTC
*** Bug 586972 has been marked as a duplicate of this bug. ***

Comment 12 releng-rhel@redhat.com 2010-07-02 19:09:21 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.