Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5930

Summary: Requires egcs to build
Product: [Retired] Red Hat Powertools Reporter: andrewem
Component: acuaAssignee: Tim Powers <timp>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-13 00:39:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description andrewem 1999-10-13 23:51:18 UTC
I understand that egcs produced better code than gcc for x86
at one time, but this was never true for all architectures
(example: gcc and egcs for ARM were always identical).
Since egcs has been merged back into gcc, more and more of
these special cased spec files are gonna be causing
headaches in the future as well.

The "CC=egcs" force is done a patch (uggh).  A possibly
better approach would be to do the following in the spec
file:

  if [ -e `type -p egcs` ] ; then \
    make CC=egcs ; \
  else \
    make ; \
  fi

Comment 1 Tim Powers 1999-10-20 16:10:59 UTC
Thanks for the tip. We'll keep an eye out for this in the next
release.