Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 592915

Summary: interface probe fails
Product: [Fedora] Fedora Reporter: Ondrej Moriš <omoris>
Component: openscapAssignee: Peter Vrabec <pvrabec>
Status: CLOSED CURRENTRELEASE QA Contact: Ondrej Moriš <omoris>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: pvrabec, theinric
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-12-08 10:43:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Testing content. none

Description Ondrej Moriš 2010-05-17 10:52:34 UTC
Description of problem:

Currently it is impossible to evaluate OVAL content containing interface objects because function oval_syschar_model_probe_objects() returns non-zero integer.

Version-Release number of selected component (if applicable):

rawhide (commit 040b186bd2933e416e168c403319d2d98e199710)

How reproducible:

always

Steps to Reproduce:

1. use tests/OVAL/probes/test_probes.c to evaluate attached content
  
Actual results:

OVAL/probes/test_probes.c:40 (main): Assumption `oval_syschar_model_probe_objects(sys_model) == 0' not fulfilled!
Aborted (core dumped)

Expected results:

Evaluation succeeded.

Additional info:

This is regression probably since evaluation proceeded without abortion before this commit (but the results were incorrect).

Comment 1 Ondrej Moriš 2010-05-17 11:18:36 UTC
Created attachment 414522 [details]
Testing content.

Comment 2 Ondrej Moriš 2010-05-20 12:26:38 UTC
Unfortunately problem is still present in commit 97cf2470d92ebb1e7c765e6252c17f95048fcf0d.

Comment 3 Bug Zapper 2010-07-30 11:39:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Ondrej Moriš 2010-12-08 10:43:57 UTC
It works fine now (commit 479f3508f231df91b59a6a3ab558345ec769d0df).