Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 591779

Summary: Does apache-commons-compress-javadoc need to obsolete jakarta-commons-compress-javadoc?
Product: [Fedora] Fedora Reporter: Bruno Wolff III <bruno>
Component: apache-commons-compressAssignee: Sandro Mathys <sandro>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: sandro
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: apache-commons-compress-1.0-5.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-14 20:43:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bruno Wolff III 2010-05-13 05:56:32 UTC
Description of problem:
When doing a yum update apache-commons-compress isn't getting installed because of a dependency issue and apache-commons-compress-doc isn't being grabbed as a replacement for jakarta-commons-compress-javadoc.
--> Running transaction check
---> Package apache-commons-compress.noarch 0:1.0-4.fc13 set to be updated
--> Processing Dependency: jakarta-commons-compress = 1.0-1.fc13 for package: jakarta-commons-compress-javadoc-1.0-1.fc13.noarch
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    apache-commons-compress-1.0-4.fc13.noarch from updates

This sure looks like there is a missing obsoletes for jakarta-commons-compress-javadoc in apache-commons-compress-javadoc.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Sandro Mathys 2010-05-13 22:11:03 UTC
Bruno, thanks for the report. You are totally right I messed up the javadoc pkg in the renaming process. Will try to fix that ASAP. Sorry for the inconvenience.

Comment 2 Fedora Update System 2010-05-13 22:28:38 UTC
apache-commons-compress-1.0-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/apache-commons-compress-1.0-5.fc12

Comment 3 Fedora Update System 2010-05-13 22:29:23 UTC
apache-commons-compress-1.0-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/apache-commons-compress-1.0-5.fc13

Comment 4 Bruno Wolff III 2010-05-14 12:26:58 UTC
The update fixes the problem and the update goes smoothly now. Thanks.

Comment 5 Sandro Mathys 2010-05-14 20:43:53 UTC
Thanks for verifying this and the feedback.

Comment 6 Fedora Update System 2010-05-15 20:20:42 UTC
apache-commons-compress-1.0-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-05-15 20:46:08 UTC
apache-commons-compress-1.0-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.