Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 591693

Summary: Segfaults with mayavi on fc13
Product: [Fedora] Fedora Reporter: Luca Giuzzi <luca.giuzzi>
Component: MayaviAssignee: Rakesh Pandit <rpandit>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: cbm, luca.giuzzi, rpandit, tomspur
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 593593 (view as bug list) Environment:
Last Closed: 2010-07-16 08:24:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Luca Giuzzi 2010-05-12 20:26:08 UTC
Description of problem:
 mayavi2 refuses to start and/or load under python; the system segfaults. 

Version-Release number of selected component (if applicable):
wxPython 2.8.10.1-3.fc13 [the version on the repositories does not
 load at all with wxGTK-2.8.11]
Mayavi 3.3.0-1.fc13
Python 2.6.4-25.fc13


How reproducible:
 it always happens



Steps to Reproduce:
1. run python
2. execute:
 from enthought.mayavi.mlab import *
3. the system crashes
  
Actual results:

Python 2.6.4 (r264:75706, Apr  1 2010, 02:56:02) 
[GCC 4.4.3 20100226 (Red Hat 4.4.3-8)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from enthought.mayavi.mlab import *

Warning: Unable to import the wx backend for pyface due to traceback: Traceback (most recent call last):
	  File "/usr/lib/python2.6/site-packages/enthought/pyface/toolkit.py", line 40, in _init_toolkit
	    __import__(be + 'init')
	ImportError: No module named wx.init





Expected results:
The interpreter loads the relevant classes; everything works

Additional info:
 1. running mayavi directly yields a segmentation fault
 2. running the programs from a different machine, suggests that after the
 error and BEFORE the segmentation fault there is an attempt to contact
 the xserver
 3. with wxPython 2.8.10.1-3.fc13 it is possible to run ipython-wx
 (which was not possible with version 2.8.10.1-1 of the same package)

Comment 1 Rakesh Pandit 2010-05-19 05:38:26 UTC
I promise, will look into this breakage. I haven't been looking into Mayavi issues for long. Will check this weekend.

Thanks for reporting.

--
Regards,
Rakesh Pandit

Comment 2 Luca Giuzzi 2010-05-19 09:19:44 UTC
*** Bug 593593 has been marked as a duplicate of this bug. ***

Comment 3 Luca Giuzzi 2010-05-19 09:22:15 UTC
That is fine, thanks a lot!
 I got a complete backtrace (via abrt) of the segfault; it filed it as a different bug, though (which I have marked as duplicate of this).

Comment 4 Fedora Update System 2010-05-20 22:42:14 UTC
telepathy-butterfly-0.5.10-1.fc13,papyon-0.4.7-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/telepathy-butterfly-0.5.10-1.fc13,papyon-0.4.7-1.fc13

Comment 5 Colin Macdonald 2010-06-08 10:13:14 UTC
Possibly related:

$ ipython -wthread
/usr/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py:14490: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
Python 2.6.4 (r264:75706, Apr  1 2010, 02:56:02) 

Finally, here is the output from mayavi2 crashing:

$ mayavi2 
Warning: Unable to import the wx backend for pyface due to traceback: Traceback (most recent call last):
	  File "/usr/lib/python2.6/site-packages/enthought/pyface/toolkit.py", line 40, in _init_toolkit
	    __import__(be + 'init')
	ImportError: No module named wx.init

/usr/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py:14490: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
Segmentation fault (core dumped)

Comment 6 Colin Macdonald 2010-06-08 11:40:58 UTC
More general than just mayavi, just importing wx outputs warnings:

$ python
Python 2.6.4 (r264:75706, Apr  1 2010, 02:56:02) 
[GCC 4.4.3 20100226 (Red Hat 4.4.3-8)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import wx
/usr/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py:14490: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")

Comment 7 Thomas Spura 2010-07-16 08:24:12 UTC
(In reply to comment #6)
> More general than just mayavi, just importing wx outputs warnings:
> 
> $ python
> Python 2.6.4 (r264:75706, Apr  1 2010, 02:56:02) 
> [GCC 4.4.3 20100226 (Red Hat 4.4.3-8)] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import wx
> /usr/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py:14490:
> UserWarning: wxPython/wxWidgets release number mismatch
>   warnings.warn("wxPython/wxWidgets release number mismatch")    

This happens with every program that uses wx, but it was never a problem anywhere (for me at least), so I'd ignore this. (Feel free to open a new bug report to proberly update wxPython, so the warning is gone.)

The segmentation faults look similar to the one in bug #615063, so this bug should be a dublicate of that.

Mayavi is a bit outdated according to:
http://pypi.python.org/pypi/Mayavi/

I'll try to update it and maybe it's fixed in a new version.

*** This bug has been marked as a duplicate of bug 615063 ***