Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 591315

Summary: AttributeError: 'NoneType' object has no attribute 'rfind'
Product: Red Hat Enterprise Linux 6 Reporter: Alexander Todorov <atodorov>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: anaconda_trace_hash:94df46f78c2824ab726b7001afc2e52d85ac852f8e27c32102a0e99e1b45fdd6
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-11 21:04:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Attached traceback automatically from anaconda. none

Description Alexander Todorov 2010-05-11 20:59:54 UTC
The following was filed automatically by anaconda:
anaconda 13.21.37 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/posixpath.py", line 111, in basename
    i = p.rfind('/') + 1
  File "/usr/lib/anaconda/storage/devicetree.py", line 1360, in handleUdevDiskLabelFormat
    bypath = os.path.basename(deviceNameToDiskByPath(device.name))
  File "/usr/lib/anaconda/storage/devicetree.py", line 1715, in handleUdevDeviceFormat
    self.handleUdevDiskLabelFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1299, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1965, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 379, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1348, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1261, in nextClicked
    self.setScreen ()
  File "/usr/lib/anaconda/gui.py", line 1398, in keyRelease
    self.nextClicked()
AttributeError: 'NoneType' object has no attribute 'rfind'

Comment 1 Alexander Todorov 2010-05-11 20:59:58 UTC
Created attachment 413261 [details]
Attached traceback automatically from anaconda.

Comment 2 Alexander Todorov 2010-05-11 21:02:15 UTC
This is with 0510.0 tree, KVM domU, newly created disk image.

Just start anaconda in graphical mode and proceed through the screens in stage2.

Comment 3 Alexander Todorov 2010-05-11 21:04:54 UTC

*** This bug has been marked as a duplicate of bug 589967 ***