Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5911

Summary: Disturbing syslog messages on gdm exit
Product: [Retired] Red Hat Linux Reporter: Patrick J. LoPresti <lopresti>
Component: gdmAssignee: Havoc Pennington <hp>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: jirka, mdrew, mkp, pthomas
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-11-16 20:26:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Patrick J. LoPresti 1999-10-13 17:29:14 UTC
Every time I log out of my GNOME session, I get the
following messages logged to /var/log/messages:


  Oct 13 11:26:47 egghead gdm[6403]: gdm_auth_user_remove:
/u/patl is not owned by uid 0.
  Oct 13 11:26:47 egghead gdm[6403]: gdm_auth_user_remove:
Ignoring suspiciously looking cookie file
/u/patl/.Xauthority


Browsing the source code for gdm, I conclude that this is
some weird gdm bug; that "uid 0" is the user who it wants to
have owning my home directory, which ought to be *my* user
id, not root's.

I do not know why this is happening, but it is pretty
disturbing.  I assume gdm manipulates my .Xauthority file
for a reason; this bug is preventing that from happening.

Comment 1 Patrick J. LoPresti 1999-10-13 17:46:59 UTC
Addenddum: I do own my home directory, and my user id is not 0.  (I
just double checked these.)

Also, similar messages are *not* logged by gdm_user_auth_add at the
beginning of the session; I only get messages from
gdm_user_auth_remove.

Let me know if you need assistance to reproduce this problem.

Comment 2 mkp 1999-11-01 19:15:59 UTC
I didn't operate on a copy of the pwent structure and apparently PAM
messes with it. I.e. we get a random userid when the session is about
to be terminated.

This bug has been fixed in my current tree and will be in beta5.

Comment 3 Elliot Lee 1999-11-17 21:39:59 UTC
Author has indicated this will be fixed in a future upstream release. Since its
impact appears to be merely cosmetic, I'm closing this bug report.

Comment 4 Peter L. Thomas 2001-08-22 16:29:02 UTC
We are receiving these error messages--accompanied by the extremely "non-
cosmetic" behavior of gdm erroring out with an 0x10.  This is happening on a 
RH6.2 and two RH7.0 boxes on an infrequent-but-annoying basis.

Comment 5 Elliot Lee 2001-09-07 19:28:34 UTC
mdrew has indicated that someone is experiencing this problem. We need to at
least attach a decent explanation to this bug file.

Comment 6 Elliot Lee 2001-09-10 23:43:15 UTC
Someone else can probably deal with this better than I.

Comment 7 Havoc Pennington 2001-09-11 15:16:08 UTC
We are pretty sure the PAM packages in the beta (roswell) resolve this issue; 
people are discussing now whether to do an errata, etc.

Comment 8 Havoc Pennington 2001-11-16 20:26:44 UTC
Need to verify that gdm is now copying the pwent structure instead of keeping a
pointer to it

Comment 9 Havoc Pennington 2002-02-12 00:04:36 UTC
Fixed in rawhide