Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 590580

Summary: PATCH: libiscsi get_firmware_foo does not work without first creating a libiscsi context
Product: Red Hat Enterprise Linux 6 Reporter: Hans de Goede <hdegoede>
Component: iscsi-initiator-utilsAssignee: Andy Grover <agrover>
Status: CLOSED CURRENTRELEASE QA Contact: Barry Donahue <bdonahue>
Severity: medium Docs Contact:
Priority: low    
Version: 6.0CC: atodorov, borgan, coughlan, mchristi, mganisin, syeghiay
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: iscsi-initiator-utils-6.2.0.872-4 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 590581 (view as bug list) Environment:
Last Closed: 2010-11-10 20:42:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 617860    
Attachments:
Description Flags
PATCH: call sysfs_init from libiscsi_get_firmware_foo none

Description Hans de Goede 2010-05-10 08:39:10 UTC
Created attachment 412756 [details]
PATCH: call sysfs_init from libiscsi_get_firmware_foo

Hi Mike,

The libiscsi_get_firmware_foo functions do not work without first creating a libiscsi context, while they are intended to work without a context. The problem is that the sysfs code needs to be initialized before use and it is used by
the fwparam code. This patch fixes this by calling sysfs_init() when
libiscsi_get_firmware_foo is called and sysfs_init was not called yet.

I'll clone this bug for 5.5 as I believe we need it there too.

Thanks & Regards,

Hans

p.s.

I can add this to pkg CVS myself if you want, but I'm not sure if I have commit rights there, only one way to find out I guess :)

Comment 1 RHEL Product and Program Management 2010-05-10 09:22:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Mike Christie 2010-05-10 17:39:12 UTC
(In reply to comment #0)
> I can add this to pkg CVS myself if you want, but I'm not sure if I have commit
> rights there, only one way to find out I guess :)    

Go ahead and commit.

If you cannot commit, then ping me, or ping whoever controls it to get those permissions since you maintain the userspace libiscsi and know the code well you should have those permissions.

Comment 3 Hans de Goede 2010-05-11 08:22:12 UTC
QA: this needs special hardware (ibft capable) to test, I'll verify this myself as soon as a build with the patch in has hit the nightlies. Can I get a QA ack on this please ?

Comment 4 Mike Christie 2010-05-19 11:54:26 UTC
Fixed in iscsi-initiator-utils-6.2.0.872-4.

Comment 9 Barry Donahue 2010-09-24 18:30:22 UTC
verified comment #6.

Comment 10 releng-rhel@redhat.com 2010-11-10 20:42:05 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.