Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 590407

Summary: [PATCH] Red Installer?
Product: Red Hat Enterprise Linux 6 Reporter: Lubomir Rintel <lkundrak>
Component: anacondaAssignee: Hans de Goede <hdegoede>
Status: CLOSED CURRENTRELEASE QA Contact: Martin Banas <mbanas>
Severity: medium Docs Contact:
Priority: low    
Version: 6.0CC: atodorov, mbanas
Target Milestone: rcKeywords: EasyFix, Patch
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: anaconda-13.21.39-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-07-02 20:48:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 597199    
Bug Blocks:    
Attachments:
Description Flags
Proposed fix none

Description Lubomir Rintel 2010-05-09 11:25:44 UTC
Created attachment 412632 [details]
Proposed fix

Description of problem:

The window title of anaconda live installer is incorrect, so is the entry it adds to grub, etc; due to product name not being correctly determined.

Version-Release number of selected component (if applicable):

anaconda-13.35-1.fc13.i686

Additional info:

Attaching a fix.

Comment 2 RHEL Product and Program Management 2010-05-09 13:57:56 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Hans de Goede 2010-05-10 09:11:04 UTC
Hi,

Thanks for the patch, I've added this patch to our master branch and will add it to RHEL-6 branch as soon as it has the necessary flags.

Regards,

Hans

Comment 4 Lubomir Rintel 2010-05-10 10:51:46 UTC
Haha, I like what you did to the commit message.
Clearly, no sense of humor at all :)

Comment 5 Hans de Goede 2010-05-10 11:10:17 UTC
(In reply to comment #4)
> Haha, I like what you did to the commit message.
> Clearly, no sense of humor at all :)    

Heh, I first planned on leaving it as is, but git am did not work, so as I needed to it manually it seemed better to fix it, it is a public git repo after all :)

Comment 6 Lubomir Rintel 2010-05-10 11:31:55 UTC
(In reply to comment #5)
> Heh, I first planned on leaving it as is

Talk is cheap, Hans, everyone could say that. It's not going to fix your reputation ;)

Comment 8 Hans de Goede 2010-05-12 08:31:57 UTC
This is fixed in anaconda-13.21.39-1, moving to modified.

Comment 10 Martin Banas 2010-05-24 09:52:06 UTC
Cannot verify until bug 595284 is fixed.

Comment 11 Martin Banas 2010-05-28 12:04:00 UTC
Window has following name:
"Red Hat Enterprise Linux Client Installer", which seems to be correct. Cannot verify the grub until bug 597199 is fixed.

Comment 12 Martin Banas 2010-06-21 07:29:32 UTC
I can't verify grub because bug 597199 was closed as wontfix. Since the title of window is correct, I mark this bug as VERIFIED.

Comment 13 releng-rhel@redhat.com 2010-07-02 20:48:46 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.