Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 589680

Summary: UEFI boot images are not being created correctly.
Product: [Fedora] Fedora Reporter: Peter Jones <pjones>
Component: anacondaAssignee: Peter Jones <pjones>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: anaconda-maint-list, awilliam, dcantrell, jlaska, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-11 00:05:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 507681    

Description Peter Jones 2010-05-06 17:07:18 UTC
Description of problem: efiboot.img and boot.iso are being created with UEFI boot images that don't actually have any data in them:

sd 36:0:0:0: [sdb] 1957888 512-byte logical blocks: (1.00 GB/956 MiB)
sd 36:0:0:0: [sdb] Assuming drive cache: write through
 sdb: unknown partition table

Version-Release number of selected component (if applicable): anaconda-13.39-1

Comment 1 James Laska 2010-05-06 18:09:37 UTC
Do we know what might be broken with the creating the UEFI boot images?  I gather we could extra compose logs if needed?

Comment 2 Peter Jones 2010-05-06 18:16:21 UTC
Well, I'm doing composes here in my attempts to fix the problem; I think it's related to tools like dmsetup and parted switching to making /dev/mapper nodes via the udev rules instead of doing it themselves. Thus, since we're in a chroot, and not bind mounting /dev (as I've always recommended we do in the past, but hey, nobody listens), udev does it at the wrong place.

Comment 3 Adam Williamson 2010-05-07 02:25:07 UTC
where are we on this? it's the last unmodified blocker now, afaict.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Jesse Keating 2010-05-07 02:41:59 UTC
There is a patch upstream that has been acked.  It just needs to be git am'd and cherry picked over to the F13 branch and then a new anaconda built.

Comment 5 Fedora Update System 2010-05-07 07:42:34 UTC
anaconda-13.41-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.41-1.fc13

Comment 6 Jesse Keating 2010-05-11 00:05:02 UTC
This fix is in and has been confirmed.