Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 589448

Summary: Could not get network after S4 in guest
Product: Red Hat Enterprise Linux 5 Reporter: Amos Kong <akong>
Component: kvmAssignee: Gleb Natapov <gleb>
Status: CLOSED DUPLICATE QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 5.6CC: ailan, knoel, virt-maint, ykaul
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-05-16 12:41:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 580948    

Description Amos Kong 2010-05-06 07:57:00 UTC
Description of problem:
Start guest and the guest can get IP and can PING host. But the guest could not
get network and ping host after S4.

But it's fine when using e1000 or rtl8139 NIC.


Version-Release number of selected component (if applicable):
host kernel: 2.6.32-19.el6.x86_64
guest kernel: 2.6.18-194.el5
# rpm -qa |grep kvm
kmod-kvm-83-164.el5_5.8
kvm-83-164.el5_5.8
kvm-qemu-img-83-164.el5_5.8
etherboot-zroms-kvm-5.4.4-13.el5
kvm-tools-83-164.el5_5.8
kvm-debuginfo-83-164.el5_5.8

How reproducible:
always

Steps to Reproduce:
1. start guest
/root/autotest/client/tests/kvm/qemu -name 'vm1' -monitor tcp:0:6001,server,nowait -drive file=/root/autotest/client/tests/kvm/images/RHEL-Server-5.5-64-virtio.qcow2,if=ide,cache=none,boot=on -net nic,vlan=0,model=virtio,macaddr=00:30:1F:42:1e:6c -net tap,vlan=0,ifname=virtio_0_6001,script=/root/autotest/client/tests/kvm/scripts/qemu-ifup-switch,downscript=no -m 8196 -smp 1 -soundhw ac97 -usbdevice tablet -rtc-td-hack -no-hpet -cpu qemu64,+sse2 -no-kvm-pit-reinjection -redir tcp:5000::22 -vnc :0 -serial unix:/tmp/serial-20100506-153156-I71N,server,nowait

2. run S4
echo disk > /sys/power/state
3. start guest by the same cmd and ping host

Actual results:
the guest cannot gets network after S4

Expected results:
the guest can gets network after S4

Comment 1 Gleb Natapov 2010-05-16 12:41:38 UTC
Close as duplicate although this bug is about rhel5. The real issue is that virtio in a guest doesn't support PM.

*** This bug has been marked as a duplicate of bug 582178 ***