Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5893

Summary: CVS 1.10.6 attempts to chdir to /root when running under pserver
Product: [Retired] Red Hat Linux Reporter: jhut
Component: cvsAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-12 20:16:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description jhut 1999-10-12 19:43:19 UTC
A working cvs pserver setup under RH 6.0 (cvs 1.10.5) now
fails to work correctly when connecting remotely via
pserver.  I receive 2 cvs server messages:

Can't chdir to root
Can't read /root/.cvsignore

The entry in /etc/inetd.conf is

cvspserver stream tcp nowait root /usr/sbin/tcpd
/usr/bin/cvs --allow-root=/home/cvsroot pserver

Comment 1 Jim Kingdon 1999-10-12 20:16:59 UTC
This is a longstanding CVS bug.  The reason that the upgrade changed
things is probably that it changed the permissions on the /root
directory (or so would be my guess).  I'd suggest taking up this
matter with the CVS lists at http://www.cyclic.com/ (of course,
being willing to write a patch always helps...).