Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5837

Summary: Installer fails to show IDE disk on box with both IDE and SCSI disks
Product: [Retired] Red Hat Linux Reporter: Nigel Metheringham <nigel.metheringham>
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-08 16:21:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nigel Metheringham 1999-10-11 16:08:29 UTC
Box is a Compaq PII/450 uniproc with IDE main disk + CD and
additional Adaptec 2940UW with disk + cd-writer on it.
A working installation of RH 6.0 was on the box completely
on the IDE disk, with just /usr/src and some junk on
the SCSI disk.

The system was booted off a RH 6.1 CD (home burnt).
It detected the SCSI OK, but then did not show the
IDE disks as available for upgrade - in fact it flopped
becuase it found no installation for upgrade.

Decabling the SCSI set and restarting made the system find
the IDE disk OK, and the upgrade then worked.

[Its a fuzzy report - come back to me with specific
questions and I'll do my best to answer]

	Nigel.

Comment 1 Anonymous 1999-10-11 16:16:59 UTC
just to make it clear - the system was booted off the IDE CD drive -
probably has no bearing... but with 2 CDs it might confuse you

Comment 2 Jay Turner 1999-10-11 18:30:59 UTC
I just tried recreating this in the test lab and had no problems, so I
am wondering what else might be at work here.  In the lab, I have a
P2B motherboard with a PII-350 and I threw in a 2940U2W card with a
SCSI drive first on ID8 and then on ID0.  Both times I was not even
asked about the partition to upgrade, as the installer found the only
installation on the IDE drive.  Wonder if there is another factor
going on here.  Any other information that you can provide which might
factor in?

Comment 3 Jay Turner 1999-10-21 16:40:59 UTC
Send me a copy of your fstab as well as output from fdisk, as we have
seen a number of problems related to those areas.

Comment 4 Jay Turner 2000-02-08 16:21:59 UTC
Bug closed due to lack of activity.