Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5836

Summary: Solaris find-requires function has a syntax error
Product: [Retired] Red Hat Linux Reporter: Nigel Metheringham <nigel.metheringham>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-11 15:48:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Nigel Metheringham 1999-10-11 15:34:46 UTC
fine-requires on solaris built rpm fails due to [ -z
being given a variable number of arguments.

Patch to fix is:-
Index: ./autodeps/solaris.req
--- ./autodeps/solaris.req      Tue Sep 21 19:34:55 1999
+++ ./autodeps/solaris.req      Mon Oct 11 16:29:54 1999
@@ -8,7 +8,7 @@
 ulimit -c 0

 filelist=`sed "s/['\"]/\\\&/g"`
-[ -z $filelist ] && exit #emulate -r option for xargs
+[ -z "$filelist" ] && exit #emulate -r option for xargs

 for f in `echo $filelist | xargs file | fgrep executable |
cut -d: -f1`; do
     ldd $f 2>/dev/null | awk '/\=\>/ { print $1 }'
#### End of Patch data ####

[didn't I used to get asked my email address - well its
nigel@pobox.com among others :-) ]

Comment 1 Jeff Johnson 1999-10-11 15:48:59 UTC
Fixed in cvs. Thanks for the report.