Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5806

Summary: Unable to set up SB128PCI (ES1371)
Product: [Retired] Red Hat Linux Reporter: dbergst
Component: sndconfigAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: dbergst, dirtynick, redhat-bugzilla, rvokal, webguy
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-05 06:06:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
audio test result of my fedora one box
audio test result of my fedora one box none

Description dbergst 1999-10-10 15:48:17 UTC
The sndconfig utility hangs when it trys to play the test

Comment 1 Bill Nottingham 1999-10-11 14:31:59 UTC
Do you get the same behavior if you do:

modprobe es1370
play /usr/share/sndconfig/

from the command line?

Comment 2 dbergst 1999-10-12 01:25:59 UTC
Prior to posting this report, I had already attempted to run the
'modprobe es1370' command and the system returned:
"/lib/modules/2.2.10/misc/es1370.o: init_module: Device or resource
busy", presumably because the system has the 1371 chip, which the BIOS
reports.  No sounds whatsoever have been playable.  In case it is
helpful, I am also posting the lspci output for this card:

00:0d.0 Multimedia audio controller: Ensoniq ES1371 (rev 07)

Comment 3 Bill Nottingham 1999-10-18 17:43:59 UTC
Does it hang if you try to play a sound from the command line
after loading the es1371 module?

Comment 4 Bill Nottingham 1999-10-18 18:35:59 UTC
Never mind that; what does
'strace play /usr/share/sndconfig/' say?

------- Additional Comments From   10/19/99 19:14 -------
Please see email attachment, From  Tue Oct 19
07:45:57 1999.

Comment 5 Bill Nottingham 1999-10-20 02:23:59 UTC
Hm... and 'play /usr/share/sounds/shutdown1.wav (or similar)
hangs as well?  What happens if you try the 2.2.12 kernel from
Raw Hide?

Comment 6 Bill Nottingham 1999-10-20 02:24:59 UTC
Also, are there any messages in the system logs?

Comment 7 dbergst 1999-10-20 11:40:59 UTC
Yes any command to play sounds hangs the system.  In addition, klogd
seems to hog the CPU whenever the es1371.o module is loaded.  From
/var/log/messages, here is the output from this morning's test:

Oct 20 07:30:59 soundman kernel: es1371: version v0.13 time 00:00:

Oct 20 07:30:59 soundman kernel: es1371: found adapter at io 0xe80
Oct 20 07:30:59 soundman kernel: es1371: features: joystick 0x0

This was with no special options in /etc/conf.modules, just did a
'modprobe es1371'.  From /var/log/dmesg the following message appears
numerous times:

snd: es1371: codec write timeout at 0xec14 [0x40000000]

I am downloading the kernel source RPM from rawhide for 2.2.12-20 and
will report back once it is installed, compiled, and retested for this
sound chip.

Comment 8 dbergst 1999-10-21 11:54:59 UTC
Due to some problems rebuilding using SRPM for kernel 2.2.12-20, used
the RPM's for the kernel sources and headers for the same version.
However, after compiling and installing the system, the behavior after
loading the es1371 module appears to be unchanged from what was
initially reported (system does not play audio files, klogd hogs CPU
at 97% until killed and restarted).  The only additional information I
can think of at this point is that two of these cards are installed
(PS - I have tried removing one of the cards previous to this test to
no avail).

uname -a
Linux 2.2.12-20 #1 Thu Oct 21 00:09:48 EDT 1999 i686

from dmesg:

es1371: version v0.13 time 00:21:58 Oct 21 1999
es1371: found adapter at io 0xe800 irq 5
es1371: features: joystick 0x0
es1371: codec vendor  revision 0
es1371: codec features none
es1371: stereo enhancement: no 3D stereo enhancement
es1371: found adapter at io 0xec00 irq 10
es1371: features: joystick 0x0
es1371: codec vendor  revision 0
es1371: codec features none
es1371: stereo enhancement: no 3D stereo enhancement
es1371: dma timed out??
es1371: dma timed out??

Comment 9 Bill Nottingham 1999-10-21 18:48:59 UTC
What do the numbers on top of the chip say?
(I've contacted the driver maintainer; there have been other reports
of this...)

Comment 10 dbergst 1999-10-22 00:11:59 UTC
These numbers appear on the surface of the main chip near the PCI
connector (bioth cards are identical):

9932H J5050A

Also, if it is any additional help, the model number of the card is

Comment 11 redhat-bugzilla 1999-12-09 15:48:59 UTC
I'm having a similar problem; perhaps it's the same.
This is the (wrapped) output of
	strace -f play

[pid 12297] write(4,
"~}}}{{|}}|{z{}~~\177\200\201\202\202\202\201\200\200\200"..., 64) = 64
[pid 12297] write(4,
"\203\202\200\177\177\200\201\202\201\201\200\200\200\200"..., 64) = 64
[pid 12297] write(4,
"\177~\177\200\201\202\202\201\200\200\200\200\177}|{{{"..., 64) = 64
[pid 12297] write(4,
"\204\203\203\203\204\206\210\211\210\207\206\204\203\201"..., 64) = 64
[pid 12297] write(4,
"}|{{{||}~\177\177\177\177\177\177\177\177\200\200\201\202"..., 64) = 64
[pid 12297] close(3)                    = 0
[pid 12297] munmap(0x40014000, 4096)    = 0
[pid 12297] write(4, "\200\200\200", 3) = 3
[pid 12297] close(4

It hangs here, of course.

Comment 12 Nick Boehling 2000-01-18 06:46:59 UTC
I have the same problem with the same card.  What is the status on this fix?

Comment 13 Bill Nottingham 2000-01-18 16:31:59 UTC
Fixed in 2.2.15pre1 or greater kernel.

Comment 14 Bill Nottingham 2000-01-21 06:24:59 UTC
*** Bug 8394 has been marked as a duplicate of this bug. ***

Comment 15 Bill Nottingham 2000-01-24 05:16:59 UTC
*** Bug 8787 has been marked as a duplicate of this bug. ***

Comment 16 Bill Nottingham 2000-01-31 19:11:59 UTC
*** Bug 8376 has been marked as a duplicate of this bug. ***

Comment 17 Bill Nottingham 2000-02-05 06:06:59 UTC
A 2.2.15-pre based kernel will be in the next Raw Hide release.

Comment 18 redhat-bugzilla 2000-06-22 17:49:30 UTC
I verified that this works with the drivers included with Red Hat Linux 6.2.

Comment 19 Taehwan Bae 2004-01-13 15:24:20 UTC
Created attachment 96945 [details]
audio test result of my fedora one box

Comment 20 Taehwan Bae 2004-01-13 15:27:45 UTC
Created attachment 96946 [details]
audio test result of my fedora one box

1. The part of dmesg on es1371 is:

es1371: version v0.32 time 20:17:31 Jan  6 2004
es1371: found chip, vendor id 0x1274 device id 0x5880 revision 0x02
es1371: found es1371 rev 2 at io 0xb800 irq 9
es1371: features: joystick 0x0
ac97_codec: AC97 Audio codec, id: 0x8384:0x7608 (SigmaTel STAC9708)
[root@localhost root]#

2. When I tried to do the below, the result is attached for your reference.

#strace play /usr/share/sndconfig/ 2> test.txt

3. What is the main problem on my linux box(Fedora Core 1)? Please give me your