Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5765

Summary: 6.1 installer no longer groks extended partions, unlike 6.0
Product: [Retired] Red Hat Linux Reporter: ancipital
Component: util-linuxAssignee: Jay Turner <jturner>
Severity: high Docs Contact:
Priority: high    
Version: 6.1CC: ancipital, csigler, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-04-17 16:54:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ancipital 1999-10-09 12:12:14 UTC
(Apologies for flagging "fdisk" as the component, I
couldn't see an entry for the installer, which is what
seems to be causing problems)

The 6.1 installer, unlike its 6.0 predecessor, doesn't grok
extended partitions. Thus, if you try to upgrade a RatHed
system which is set up in this manner, it will insist that
you "don't have any linux partitions" and refuse to play
with you at all.

Not happy! The only workaround I can see will take longer
than installing from scratch, and reconfiguring- rebuilding
my filesystems, and completely repartitioning all the

Comment 1 csigler 1999-10-13 20:47:59 UTC

I've had this problem as well.  The error message I got on two very
diverse i386 systems was "You don't have any Linux partitions."
The upgrade refused to run.  This happened after clicking on the
"Upgrade" radio button then next in the installer.

This is a critical problem, but is easily solved by a competent
sysadmin.  These two systems had exactly one thing in common -- a
Win95 Extended Partition (LBA), partition type "f" instead of "5" for
the extended partition.

I ran fdisk to change the extended partition to type "5" on both
systems and this solved it, and the upgrades went flawlessly.

                                        Clemmitt Sigler

------- Additional Comments From   10/14/99 05:14 -------
Indeed, however, when you have a FAT32 partn in the extended partition
too, things are a little more tricky.

I found that the simplest way was to use fdisk (linux, not DOS) to
make some more ext2 partitions, and xfer everything to those, and
generally rebuild stuff.. :)

The only gotcha was that I forgot to check what the default partition
type was- it was ext2fs as created by fdisk.. This is sensible, of
course. However, like an idiot, I merrily went and mkswapped, and
started swapping onto the new partition, without going back to fdisk
and checking the partition table. Linux will cheerfully swap to the
drive with the type set to ext2fs, though.

HOWEVER, the 6.1 installer tries really hard to mount that partition
as e2 and just grinds to a halt, apparently with no timeout or
bailout. That one took a couple of mins to fix, once I got my brain in
focus. My bad, but the law of averages suggests that it might happen
to other folks, too.

Anyway, I have it all working now, but I thought it'd be an idea to
submit these probs, since the sort of people who will have the most
difficulty aren't experienced linux users or admins, natch.

Maybe just an advisory in the errata section would be sufficient,
since it is possible to work around the problem, just annoying at

Comment 2 Jay Turner 2000-04-17 16:54:59 UTC
This issue is resolved in the latest installer (Red Hat Linux 6.2)