Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5702

Summary: WU-FTPD Refuses to login all zsh account users.
Product: [Retired] Red Hat Linux Reporter: mrchumple
Component: wu-ftpdAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-18 16:42:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description mrchumple 1999-10-07 22:43:06 UTC
The default /etc/shells file doesn't have /bin/zsh in it.
After upgrading to 6.1, all user zsh accounts cannot login
to the ftp server because wu-ftpd doesn't think their shell
is allowed.  When we added '/bin/zsh' to /etc/shells our
problem disappeared.  Maybe the zsh rpm needs to add
/bin/zsh to the /etc/shells file.

Comment 1 Alan Cox 1999-10-15 20:46:59 UTC
Confirmed: Someone forgot to put zsh in /etc/shells.

Comment 2 Bernhard Rosenkraenzer 2000-01-18 16:42:59 UTC
Rawhide's zsh puts itself in /etc/shells, so this is fixed.