Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5675

Summary: Upgrade fails to detect root on /dev/hda5
Product: [Retired] Red Hat Linux Reporter: Tim Mann <redhat-bugzilla>
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: redhat-bugzilla, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-20 20:21:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tim Mann 1999-10-07 07:29:13 UTC
My experience doesn't quite match other posters reporting
similar bugs.  In my existing Red Hat 6.0 system, I don't
have any NTFS or HPFS partitions, and the root is on the
first drive, but the installer still fails.  It says
(quoting from memory, sorry) "I can't do an upgrade because
you have no existing Linux partitions".  I don't find any
other error messages, and it does not retry looking for
existing partitions.

If I press Ctrl+Alt+F2, create a device node for /dev/hda,
and look at it with fdisk, fdisk sees all the partitions
correctly.

Here is my fstab:
/dev/hda5   /              ext2    defaults             1 1
/dev/hda1   /c             vfat    gid=30060,umask=002  0 0
/dev/hda7   /d             vfat    gid=30060,umask=002  0 0
/dev/hdb5   /e             vfat    gid=30060,umask=002  0 0
/dev/hda6   swap           swap    defaults             0 0
/dev/fd0    /mnt/floppy    auto    noauto,user          0 0
/dev/fd1    /mnt/fiveinch  auto    noauto,user          0 0
/dev/cdrom  /mnt/cdrom     iso9660 noauto,ro,user       0 0
/dev/cdrom2 /mnt/cdrom2    iso9660 noauto,ro,user       0 0
none        /proc          proc    defaults             0 0
none        /dev/pts       devpts  mode=0622            0 0



------- Additional Comments From   10/16/99 22:46 -------
The problem occurred because my /dev/hda5 is an extended partition
inside a primary partition of type 0xf, as discussed in the comments
on bug 5555.  I was able to do an upgrade by temporarily changing the
primary partition type.

Comment 1 Jay Turner 1999-10-20 20:21:59 UTC
We are releasing an errata fix for this problem the week of October
18th.  Am discarding bug as details are covered in #5555, please see
that bug for further details.