Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 562

Summary: cookie handling needs work
Product: [Community] Bugzilla Reporter: Need Real Name <aander07>
Component: Bugzilla GeneralAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 2.1rC   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-22 14:25:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 1998-12-22 22:13:41 UTC
the whole confirm_login and cookie handling needs to be
re-thought.  if a user doen't have the cookies set, does a
query and logs in before buglist comes up, then the BUGLIST
cookie will be displayed to their screen.

confirm_login should probably be re-written to return an
array of cookies that the cgi's can deal with as they see
fit, rather than sending its own header and cookies out.

Comment 1 Need Real Name 1999-03-22 14:25:59 UTC
ok, it looks like cookie handling has finally reached a sane state.  I
cannot find any code paths now that print cookie headers incorrectly.