Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5591

Summary: disk druid refuses to change system id of existing partitions
Product: [Retired] Red Hat Linux Reporter: pommnitz
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-22 18:14:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description pommnitz 1999-10-05 16:34:55 UTC
I tried (and in the meantime suceeded) to install a dual
boot system with NT4.0 and RedHat-6.1. To do this I used the
NT harddisk manager to create a number of partitions that I
wanted to use under Linux. NT labeled these partitions as
DOS FAT16. Later, during RH6.1 installation, I was unable to
use the DiskDruid to change the partition types to Linux and
Linux swap. I had to resort to the command line fdisk
program to do this.

Comment 1 Jay Turner 1999-10-20 19:13:59 UTC
Disk Druid will not allow you to change many details about existing
partitions, only the mount point basically.  This is a safety measure
so that people do not change the partition types of stuff that already
existed when they started the installer.  You would have had to delete
the partitions you are referring to and then recreate them in Disk
Druid in order to change their type.  This is not a bug therefore.

Comment 2 pommnitz 1999-10-21 11:37:59 UTC
In my experience Winxx is very picky about partitions. Modifying the
partition table behind Windows' back is almost always a recipe for
desaster.
In order to be a replacement for fdisk during the install process
DiskDruid should be at least as powerful as fdisk.

Comment 3 Jay Turner 1999-10-22 18:14:59 UTC
Disk Druid is meant to be a safe replacement for fdisk, not a complete
replacement.  This is the reason that it makes certain assumptions,
like not changing the ID of existing partitions and requiring swap
partitions to be created.  If you would like more power than this,
then fdisk is available to you.