Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5508

Summary: rpmfind catches sig13
Product: [Retired] Red Hat Linux Reporter: Chris Kloiber <chris_kloiber>
Component: rpmfindAssignee: Jeff Johnson <jbj>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: bammi
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-07-26 12:05:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Kloiber 1999-10-04 20:12:19 UTC
Any attempt to download rpm packages using the rpmfind
utility included with Red Hat 6.1 results (eventually) in a
sig 13 error while trying mirror sites. To see this error
(repeatable) try "rpmfind perl-MD5" or "rpmfind listar".
When you are asked if you want to download the files to /tmp
respond with an "a". ("Y" will also lead to the same error,
but it takes longer) rpmfind will fail to get the package,
then attempt known mirrors. After the second attempt it
seems to race through all the others without really trying,
terminating with the error message:

rpmfind version 1.2 caught signal 13

In /tmp, a Zero byte file is created with the correct
filename. As near as I can tell, no core file is generated.

Chris Kloiber

Comment 1 Jeff Johnson 2000-07-26 12:05:22 UTC
Upgrade (by rebuilding) rpmfind-1.4 or later. I can't reproduce the problem with
that version.

Comment 2 Daniel Veillard 2001-07-17 22:53:20 UTC
Seems a really outdated bug report, should be fixed in more recent versions.

Daniel