Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 548783

Summary: gcc doesn't build against xulrunner-devel-1.9.2
Product: [Fedora] Fedora Reporter: Jakub Jelinek <jakub>
Component: gccAssignee: Andrew Haley <aph>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 13CC: atu, dbhole, jakub
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 596097 (view as bug list) Environment:
Last Closed: 2011-06-27 14:42:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 596097    
Attachments:
Description Flags
Patch to remove gcjwebplugin from the gcc rpm none

Description Jakub Jelinek 2009-12-18 15:40:50 UTC
gcc (including 4.5) doesn't build against xulrunner-devel-1.9.2:

In file included from /usr/include/xulrunner-sdk-1.9.2/nsAString.h:43,
                 from /usr/include/xulrunner-sdk-1.9.2/nsSubstring.h:40,
                 from /usr/include/xulrunner-sdk-1.9.2/nsString.h:44,
                 from /usr/include/xulrunner-sdk-1.9.2/nsIPluginInstance.h:26,
                 from ../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:65:
/usr/include/xulrunner-sdk-1.9.2/nsStringFwd.h:49:2: error: #error Internal string headers are not available from external-linkage code.
In file included from /usr/include/xulrunner-sdk-1.9.2/nsAString.h:64,
                 from /usr/include/xulrunner-sdk-1.9.2/nsSubstring.h:40,
                 from /usr/include/xulrunner-sdk-1.9.2/nsString.h:44,
                 from /usr/include/xulrunner-sdk-1.9.2/nsIPluginInstance.h:26,
                 from ../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:65:
/usr/include/xulrunner-sdk-1.9.2/nsTSubstring.h:40:2: error: #error Cannot use internal string classes without MOZILLA_INTERNAL_API defined. Use the frozen header nsStringAPI.h instead.
In file included from /usr/include/xulrunner-sdk-1.9.2/nsAString.h:69,
                 from /usr/include/xulrunner-sdk-1.9.2/nsSubstring.h:40,
                 from /usr/include/xulrunner-sdk-1.9.2/nsString.h:44,
                 from /usr/include/xulrunner-sdk-1.9.2/nsIPluginInstance.h:26,
                 from ../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:65:
/usr/include/xulrunner-sdk-1.9.2/nsTSubstring.h:40:2: error: #error Cannot use internal string classes without MOZILLA_INTERNAL_API defined. Use the frozen header nsStringAPI.h instead.
In file included from /usr/include/xulrunner-sdk-1.9.2/nsReadableUtils.h:51,
                 from /usr/include/xulrunner-sdk-1.9.2/nsString.h:52,
                 from /usr/include/xulrunner-sdk-1.9.2/nsIPluginInstance.h:26,
                 from ../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:65:
/usr/include/xulrunner-sdk-1.9.2/nsTArray.h:46:15: error: new: No such file or directory
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:66:35: error: nsIPluginInstancePeer.h: No such file or directory
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:67:31: error: nsIPluginTagInfo2.h: No such file or directory
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:149: error: 'NS_IPLUGINTAGINFO2_IID' was not declared in this scope
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:207: error: ISO C++ forbids declaration of 'nsIPluginTagInfo2' with no type
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:207: error: expected ';' before '*' token
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc: In function 'gchar* plugin_get_documentbase(NPP_t*)':
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:877: error: 'nsIPluginInstancePeer' was not declared in this scope
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:877: error: 'peer' was not declared in this scope
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:879: error: 'nsIPluginTagInfo2' was not declared in this scope
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:879: error: 'pluginTagInfo2' was not declared in this scope
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:891: error: 'class nsIPluginInstance' has no member named 'GetPeer'
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:898: error: 'union info_union' has no member named 'info_field'

Google found http://icedtea.classpath.org/hg/icedtea6?cmd=changeset;node=8353f4e67ec1 changes to IcedTea plugin, perhaps those might be usable to some extent.  This is a blocker for gcc in f13..

Comment 1 Andrew Haley 2009-12-18 17:18:13 UTC
I believe the plan is to remove gcjwebplugin entirely.

As far as I am aware it's simply a matter of removing 

--enable-plugin

from the specfile

Deepak, please confirm.

Comment 2 Deepak Bhole 2009-12-22 03:03:02 UTC
Created attachment 379759 [details]
Patch to remove gcjwebplugin from the gcc rpm

(In reply to comment #1)
> I believe the plan is to remove gcjwebplugin entirely.
> 
> As far as I am aware it's simply a matter of removing 
> 
> --enable-plugin
> 
> from the specfile
> 
> Deepak, please confirm.  

In addition to that, references to gcjwebplugin.so need to be removed as well.

Attached patch fixes this bug.

Comment 3 Jakub Jelinek 2009-12-22 11:33:40 UTC
I'll do that (conditionally for now, as the same gcc.spec is used for RHEL6/F12/F13 and for RHEL6/F12 we can and probably should still build it).

That said, do you have any plans for upstream GCC 4.5?  Should gcjwebplugin be removed there, or just error out during configury that --enable-plugin must not be used with xulrunner 1.9.2 and above, or something else?

Comment 4 Deepak Bhole 2009-12-22 17:52:09 UTC
The plugin should be removed from upstream as well, IMO. It is no longer actively maintained. The plugin in IcedTea is where all upstream development now happens.

Comment 5 Bug Zapper 2010-03-15 13:37:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Bug Zapper 2011-06-02 17:05:16 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Bug Zapper 2011-06-27 14:42:38 UTC
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.