Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5477

Summary: THIS IS FOR REDHAT 6.1: Setup hangs trying to mount NTFS partition as ext2
Product: [Retired] Red Hat Linux Reporter: Gerben Roest <g.roest>
Component: setupAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-05 15:26:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gerben Roest 1999-10-03 12:21:20 UTC
In the graphical install shell, I wanted to perform an
update of 6.0 to 6.1. While "checking for previous Red Hat
installations", setup tried to check or mount my
/dev/sdb6, which is an NTFS partition, and it said:

error mounting ext2 partition: invalid option.

After that, it hung. It did so even in expert mode.

Comment 1 Trond Eivind Glomsrød 1999-10-05 11:48:59 UTC
PATCH:

--- /mnt/cdrom/misc/src/anaconda/balkan/dos.c   Sat Sep 11 17:47:28
1999
+++ dos.c       Tue Oct  5 13:34:16 1999
@@ -139,6 +139,7 @@

              case 0x7:
                table->parts[i].type = BALKAN_PART_NTFS;
+               break;

              case 0x83:
                table->parts[i].type = BALKAN_PART_EXT2;

Comment 2 Bill Nottingham 1999-10-05 15:26:59 UTC
*** This bug has been marked as a duplicate of 5567 ***