Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5472

Summary: Errors in spec file for t1lib 0.9.1-2
Product: [Retired] Red Hat Powertools Reporter: andrewem
Component: t1lib-0.7.1Assignee: Tim Powers <timp>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-25 14:40:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description andrewem 1999-10-01 22:22:24 UTC
1) The spec file has "./configure
--prefix=$RPM_BUILD_ROOT/usr".  This causes the wrong
configuration directory path to be built into the library.

Using %configure alone and specifying in the %install
section "make prefix=$RPM_BUILD_ROOT/usr install" solves the
problem.

2) The spec file should use a version macro, as the version
is explicity used in several places.  Including a README
file which is not found because of the wrong version listed.

3) Symbolic links for libraries should not be made in a spec
file.  This is the job of ldconfig.

These are common mistakes that all spec files should be
checked for.

Comment 1 Tim Powers 1999-10-25 14:40:59 UTC
Thanks. Didn't catch that one for some reason (why, I have no idea).

Thanks for the heads up!

Tim