Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5435

Summary: ypbind started before pcmcia
Product: [Retired] Red Hat Linux Reporter: gerald
Component: ypbindAssignee: Cristian Gafton <gafton>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: libhart
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-04 02:35:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description gerald 1999-09-29 15:19:10 UTC
ypbind is started before pcmcia. Hence network (eth) is
not available and communication with the server will fail
at bootup.

Comment 1 David Lawrence 1999-09-29 17:10:59 UTC
This should still work because ypbind will keep trying to bind to a
NIS server even after failing the first time. Does it never connect at
all?

Comment 2 m.reid 1999-09-29 20:52:59 UTC
Though the standard setup still worked on my laptop, it is very
annoying to have [Failed] messages when the network attempts to start,
and changing the pcmcia link to occur before the network gives better
diagnotic messages about what the ethernet/modem card is, etc, etc, so
I hope that this will be fixed.

Comment 3 Bill Nottingham 1999-10-26 20:51:59 UTC
*** Bug 4229 has been marked as a duplicate of this bug. ***

Ypbind won't bind before a few minutes after startup with
pcmcia starting at /etc/rc.d/init.d/S45pcmcia.  This is
because there is no way to bind if a pcmcia network card is
the only interface and ypbind is starting at S13.  In
keeping with convention, the kill for pcmcia is listed as
S96pcmcia.  As most kill/start combinations add to 100, the
S45pcmcia links in /etc/rc.d/rc3.d rc4.d and rc5.d should
all be changed to S04pcmcia.  When ypbind runs it
will bind immediatly, allowing for logins from NIS passwd
maps.

Comment 4 David Hinds 2000-01-10 20:57:59 UTC
In general, you really should not rely on the order of execution of startup
scripts to ensure that a PCMCIA device is ready when some other startup event
happens.  Aside from the issue that a PCMCIA device may simply not be present at
boot time, running the PCMCIA startup script causes devices to be configured in
the background, and a card may or may not be ready when the next init script
gets control.  Some PCMCIA cards take a fair amount of time to be fully
initialized (the power-up sequence can take several seconds, transceiver
autonegotiation can take several seconds, etc).  Shuffling the order of the boot
scripts may appear to be a good fix in certain specific cases, but it really is
not a general solution.

Comment 5 Cristian Gafton 2000-02-04 02:35:59 UTC
with pcmcia we can not make sure that ypbind starts after the networking has
been initalized. Because of the way pcmcia works, the ethernet initialization is
done in background and there is not much one can do to find out when the network
is up and running.