Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5429

Summary: soundsupport for Neomagic
Product: [Retired] Red Hat Linux Reporter: Trond Eivind Glomsrød <trondeg>
Component: sndconfigAssignee: Bill Nottingham <notting>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: rvokal, smooge
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-29 14:50:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Trond Eivind Glomsrød 1999-09-29 06:29:12 UTC
6.1.85

Soundsupport for my Dell 3500 wasn't a wise thing to do (I
definitely seem to have my share of sound-related
problems...) - sndconfig crashed the machine hard, after
detecting the Neomagic 256 sound "card" (it's a laptop).

Bad enough.

The real bad part was that it had created a conf.modules and
tried to load the sound module - which crashed the computer
hard every time. Turning off the sound from the BIOS didn't
help - I could never get into the system. And (this is bad)
-  using single user mode didn't work either, as it still
tried to load the module which crashed the computer.

Comment 1 Bill Nottingham 1999-09-29 14:50:59 UTC
The absolute latest sndconfig, after selecting but before
loading the Neomagic driver, pops up a warning that says'
"This driver is known to lock Dell Inspiron 3500s;  are you
sure you wish to continue?"

Admittedly, it's a band-aid.
We'll look at fixing the driver for an update.

Comment 2 Bill Nottingham 1999-09-29 16:24:59 UTC
*** Bug 5382 has been marked as a duplicate of this bug. ***

If your system contains certain sound cards (Dell Inspiron
3500 ) you can end up with a locked system that can only be
edited from a rescue mode.

The problem is that sndconfig edits /etc/conf.modules before
it tests if your system has a working sound card. On
installing module it can crash the system. If you reboot you
cannot get around the modules being loaded even if you do
a linux single because of /etc/conf.modules syntax.

Suggested Fix:
a)  have sndconfig test modules via explicit insmod commands
and at end of run write /etc/conf.modules
b) have initscripts not load sound modules in single user
mode

------- Additional Comments From notting@redhat.com  09/26/99 18:57 -------
FWIW, sndconfig does tell you it's writing a new
conf.modules. :)

Boot with "linux nomodules"; alternatively "linux init=/bin/bash".