Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5422

Summary: new initscripts (4.48-1) cause reboot / halt to fail
Product: [Retired] Red Hat Linux Reporter: Hans de Goede <j.w.r.degoede>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-01 16:20:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hans de Goede 1999-09-28 20:38:07 UTC
The new /etc/rc.d/init.d/halt contains:

remaining =`awk
'!/(^#|proc|^none|^\/dev\/root|^\/dev\/hda1)/ {print $2}'
/proc/mounts`

my /proc/mount contains:

/dev/hda1 / ext2 rw 0 0
none /dev devfs rw 0 0
/proc /proc proc rw 0 0
/dev/hda5 /home ext2 rw 0 0
/dev/hda6 /archive ext2 rw 0 0
/dev/hda7 /usr/local ext2 rw 0 0
/dev/hda3 /archive/system/updates/lorax ext2 rw 0 0

as you can see root is /dev/hda1 not /dev/root, so it is
seen as a remaining filesystem to unmount.

Making things worse the halt scripts exits (after the place
where it should break) for some reason instead of retrying
 the 3 times and then continuing with rebooting. This causes
init to print:
no more processes left in runlevel.

And then it just hangs.

Comment 1 Bill Nottingham 1999-09-28 21:19:59 UTC
It exits because it killed itself, most likely.

How do you boot your system so that /proc/mounts ends up
like that?

Comment 2 Hans de Goede 1999-09-28 21:42:59 UTC
I don't know I use a default redhat install, no modifications.
Except that I run a custom kernel with devfs, but that shouldn't
matter.

Afaik I've seen the /dev/root entry in /proc/mounts with devfs too,
so I don't know why it is /dev/hda1 now. Maybe it has got something
todo with the way it is remounted?

Comment 3 Bill Nottingham 1999-09-29 14:51:59 UTC
That *shouldn't* be a problem. Could you try booting a kernel
without devfs to see if it's entered as /dev/root?

Comment 4 Hans de Goede 1999-10-01 14:43:59 UTC
Okay, it does work with the standard 2.2.12-16 kernel as distributed
with the latest lorax.

But I still think it should not behave as it does, it might yell, but
it shouldn't exit without unmounting /

Comment 5 Bill Nottingham 1999-10-01 16:20:59 UTC
This should be fixed in initscripts-4.49-1, which will be
in the next Raw Hide release.

Just trying to make sure that it did seem to be devfs, so we can
diagnose it better if it pops up again.:)

If you want to fix it on your own, change the awk to:

'!(^#|proc|^none|^\/dev\/root| \/ )/ {print $2}'
in both places...