Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5378

Summary: possible error in startkde - 1.1.2-9
Product: [Retired] Red Hat Raw Hide Reporter: Gene Czarcinski <genec>
Component: gnome-audioAssignee: Preston Brown <pbrown>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-30 17:26:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gene Czarcinski 1999-09-26 19:15:55 UTC
kdebase-1.1.2-9 introduces some additional code in startkde
so that IF there is NO sound card THEN kaudioserver and
kwmsound are not started.

The 19990923 version of rawhide is a bit screwed up so that
I have been unable to install it but I have installed all of
the 1.1.2 version of kde on a rhl 6.0 system.  The previous
(1.1.2-6) version of kdebase worked OK and I then updated to
the 1.1.2-9 version -- sound stopped working.

The problem is that startkde looks for (executes) the file
/etc/sysconfig/sound and this file does not exist (at least
on my rhl 6.0 system and on lorax 6.0.55 -- the file should
be /etc/sysconfig/soundcard (I think).  Unless something
else changed in the rawhide version of the system, this
needs to be fixed.

Good idea to look for the existance of the soundcard before
starting kaudioserver and kwmsound!

BTW, this is assigned to "gnome-audio" rather than kdebase
because the kde components are NOT defined for rawhide!

Gene C.

Comment 1 Preston Brown 1999-09-27 17:13:59 UTC
unfortunately, this probably won't make it for 6.1.  However, the RPMs
that will be available on the KDE site and as updates for 6.x will
have the fix.

Comment 2 Gene Czarcinski 1999-09-29 10:39:59 UTC
fixed in kdebase-1.1.2-11 which is in "updates" for 6.0.  I hope this
means that it will be in lorax.