Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5345

Summary: vsnprintf error
Product: [Retired] Red Hat Linux Reporter: spock
Component: man-pagesAssignee: Cristian Gafton <gafton>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-10-05 06:08:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description spock 1999-09-24 08:30:24 UTC
The man page for vsnprintf states:
RETURN VALUE
     If  the output was truncated, the return value is -1,
otherwise it is the number of characters stored, not
including the terminating null.

That is not the case.  If I give it a string 10 characters
long, and ask it to print out a string with 18 characters
vnsprintf will return 18, and not -1.  If this is not
considered a bug in the in man page, then it's the
implementation of vsnprintf.

Comment 1 Cristian Gafton 1999-10-05 06:08:59 UTC
The man page that I have states:
RETURN VALUE
       If the output was truncated, the return value is -1, otherwise
it is the number of characters
       stored,  not including the terminating null.  (Thus until glibc
2.0.6.  Since glibc 2.1 these
       functions return the  number of characters (excluding the
trailing  null)  which  would  have
       been written to the final string if enough space had been
available.)

Thus, the behavior (as mandated by Single Unix Specification ver 2) is
documented also in the man page.