Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5270

Summary: RFE: %pre(un) and %post(un) scripts should know what files were installed
Product: [Retired] Red Hat Raw Hide Reporter: Tim Mooney <mooney>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: jbj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-21 14:55:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tim Mooney 1999-09-21 14:55:07 UTC
Currently, there's no way to get a list of what files
were installed (full paths preferred, since the person
running rpm may relocate the package in many cases) from
a %pre or %post, and ditto for files removed in a %preun
%postun.  This information would often be extremely useful
to have.

Comment 1 Jeff Johnson 2002-07-13 20:04:07 UTC
rpm-4.1 permits concurrent access to the rpm
database, so the list of files can be gleaned
by doing, say,
	%post
	FILES="`rpm -ql %{name}-%{version}-%{release}`"
	...
Watch out for multiply installed pacakges however ...