Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5135

Summary: emacs -nw seg faults on exit
Product: [Retired] Red Hat Linux Reporter: harris
Component: emacsAssignee: Cristian Gafton <gafton>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: harris, richard
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-16 13:37:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description harris 1999-09-14 18:50:24 UTC
"emacs -nw" seg faults on exit

> rpm -qf /usr/bin/emacs
emacs-X11-20.3-15
> emacs -nw junk
// edit file and then exit (c-x c-c)
// gives the result
Fatal error (11).Segmentation fault (core dumped)

Comment 1 richard 1999-11-09 11:40:59 UTC
I had an exact duplicate of this error (infact, emacs --version dies
similairly) - Installing emacs 20.4.1 (from ftp.emacs.org) and
libtermcap-2.0.8-15.i386.rpm appears to, erm, 'fix', the problem.

I'm not too sure that libtermcap is necessary or related though.

Comment 2 Bernhard Rosenkraenzer 2000-02-16 13:37:59 UTC
This is fixed in 6.1 and 6.2.