Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 508422

Summary: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 15: ordinal not in range(128)
Product: [Fedora] Fedora Reporter: Florent Le Coz <louizatakk>
Component: yumAssignee: Seth Vidal <skvidal>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: admin, covex, fedora, ffesti, james.antill, juergen.bullinger, martin.bund, mschmidt, nalimilan, pahan, paw980, petsof, pj, pmatilai, resver, tla, wrzoski
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-07 14:46:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Florent Le Coz 2009-06-27 00:49:06 UTC
Description of problem:
just by doing :
yum provides gajim

We get this traceback :

Correspondance depuis :
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 178, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 352, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 560, in doCommand
    return base.provides(extcmds)
  File "/usr/share/yum-cli/cli.py", line 829, in provides
    callback_has_matchfor=True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2027, in searchPackageProvides
    callback(po, tmpvalues, args)
  File "/usr/share/yum-cli/output.py", line 870, in matchcallback_verbose
    return self.matchcallback(po, values, matchfor, verbose=True)
  File "/usr/share/yum-cli/output.py", line 864, in matchcallback
    print self.fmtKeyValFill(key, item)
  File "/usr/lib64/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 15: ordinal not in range(128)

Version-Release number of selected component (if applicable):
3.2.23

How reproducible:
Always

Additional info:
Note that this may be caused by the fact that yum is translated in French (I'm using a french-localized Fedora) and may not be reproducible with other languages.

Comment 1 Andrew Nayenko 2009-08-02 17:01:29 UTC
I get a similar crash on Fedora 11 x86_64 with Russian locale when trying to install a package from rawhide (yum crashes after hitting 'y'):

$ sudo yum update --enablerepo=rawhide gtk-murrine-engine
...
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 261, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 424, in doTransaction
    print to_utf8(msg)
  File "/usr/lib64/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 29: ordinal not in range(128)

When I explicitly set locale to 'C' I get the following:

$ LANG=C sudo yum update --enablerepo=rawhide gtk-murrine-engine
...
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) <= 5.2-1 is needed by gtk-murrine-engine-0.90.3-2.fc12.x86_64
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])

Looks like yum crashed on attempt to print a localized error message.

Steps to reproduce:
1. Run command "sudo yum update -y --enablerepo=rawhide gtk-murrine-engine" with Russian locale.

Actual result:
yum crashes.

Expected result:
Error message about rpmlib incompatibility either in English or in Russian.

How reproducible:
Always

Version-Release number of selected component (if applicable):
yum-3.2.23-3.fc11.noarch
rpm-4.7.0-2.fc11.x86_64

Additional info:

$ locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=

Comment 2 Sebastian Vahl 2009-08-05 07:09:15 UTC
I'm also getting this behaviour with "yum provides", but only if the rpm I'm searching for is installed. If it is not installed the output is fine. Eg.

# rpm -q perl-Finance-Quote
perl-Finance-Quote-1.13-3.fc11.noarch
# rpm -q perl-Finance-Quote
perl-Finance-Quote-1.13-3.fc11.noarch

[...]

perl-Finance-Quote-1.13-3.fc11.noarch : A Perl module that retrieves stock and mutual fund quotes
Repo        : fedora
Übereinstimmung von:
Andere     : perl(Finance::Quote)



perl-Finance-Quote-1.13-3.fc11.noarch : A Perl module that retrieves stock and mutual fund quotes
Repo        : installed
Übereinstimmung von:
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 178, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 352, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 560, in doCommand
    return base.provides(extcmds)
  File "/usr/share/yum-cli/cli.py", line 829, in provides
    callback_has_matchfor=True)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 2027, in searchPackageProvides
    callback(po, tmpvalues, args)
  File "/usr/share/yum-cli/output.py", line 870, in matchcallback_verbose
    return self.matchcallback(po, values, matchfor, verbose=True)
  File "/usr/share/yum-cli/output.py", line 864, in matchcallback
    print self.fmtKeyValFill(key, item)
  File "/usr/lib/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 20: ordinal not in range(128)

Comment 3 Peter 2009-10-06 05:43:02 UTC
I am getting the same err, dont know why; last day worked ok :)


[petsof@c02-505a ~]$ yum info vlc
Loaded plugins: fastestmirror, presto, refresh-packagekit, rpm-warm-cache
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 311, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 180, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 349, in doCommands
    self._getTs(needTsRemove)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 100, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 111, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 702, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 538, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 277, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 164, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 222, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1222, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1386, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1378, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1368, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1351, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1197, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 976, in _getFileRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 797, in _getFile
    result = self.grab.urlgrab(misc.to_utf8(relative), local,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 498, in <lambda>
    grab = property(lambda self: self._getgrab())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 493, in _getgrab
    self._setupGrab()
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 482, in _setupGrab
    self._grab = mgclass(self._grabfunc, self.urls,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 655, in <lambda>
    urls = property(fget=lambda self: self._geturls(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 652, in _geturls
    self._baseurlSetup()
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 606, in _baseurlSetup
    mirrorurls.extend(self._getMirrorList())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1625, in _getMirrorList
    print "Could not retrieve mirrorlist %s error was\n%s" % (url, e)
  File "/usr/lib/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 173: ordinal not in range(128)



[petsof@c02-505a ~]$ uname -a
Linux c02-505a 2.6.30.8-64.fc11.i686.PAE #1 SMP Fri Sep 25 04:56:58 EDT 2009 i686 athlon i386 GNU/Linux

Comment 4 paw980 2009-10-06 07:19:14 UTC
I found that rpmfusion.org had problem, If I turn off these repositories, at me work,
maybe problem about LANG
LANG=C yum upgrade - it work
sorry my bad english

Comment 5 Thomas Janssen 2009-10-06 10:06:27 UTC
*** Bug 527393 has been marked as a duplicate of this bug. ***

Comment 6 Adam Pribyl 2009-10-07 10:57:49 UTC
Not sure if this is exactly the same, but here is my traceback and when it occured:

Today my ISP was doing some repair on their network structure. During the day
when the connection to the internet was not available (while local network
worked), I got every hour or so a bit annoying window with a message about
unrecoverable error. This trace was attached:

Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2151, in
get_updates
    ygl = self.yumbase.doPackageLists(pkgnarrow='updates')
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1733, in
doPackageLists
    for (n,a,e,v,r) in self.up.getUpdatesList():
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 715, in
<lambda>
    up = property(fget=lambda self: self._getUpdates(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 595, in
_getUpdates
    self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(),
self.pkgSack.simplePkgList())
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 702, in
<lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 538, in
_getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 277, in
populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 164, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 222, in
_check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1222, in
_check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1386, in
<lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1378, in
_getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1368, in
_loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1351, in
_groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1192, in
_commonLoadRepoXML
    if self._latestRepoXML(local):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1170, in
_latestRepoXML
    repomd = self.metalink_data.repomd
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 699, in <lambda>
    metalink_data = property(fget=lambda self: self._getMetalink(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 681, in
_getMetalink
    print "Could not get metalink $s error was \n$s" $(url, e)
  File "/usr/lib64/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 151:
ordinal not in range(128)

Originaly reported as packagekit bug at http://bugs.freedesktop.org/show_bug.cgi?id=24367

Comment 7 seth vidal 2009-10-07 14:46:52 UTC
fixed upstream

Comment 8 Pavel Alexeev 2009-12-22 16:54:01 UTC
I also bump to this error:
# yum provides '*/antiword' '*/catdoc' '*/word2x'
Loaded plugins: aliases, dellsysidplugin2, downloadonly, fastestmirror, list-data, presto, verify
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 311, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 180, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 349, in doCommands
    self._getTs(needTsRemove)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 100, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 111, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 702, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 538, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 249, in populateSack
    self.doSetup()
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 83, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 177, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 182, in postreposetup_hook
    if downgrade_ftp and _len_non_ftp(repo.urls) == 1:
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 655, in <lambda>
    urls = property(fget=lambda self: self._geturls(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 652, in _geturls
    self._baseurlSetup()
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 606, in _baseurlSetup
    mirrorurls.extend(self._getMirrorList())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1625, in _getMirrorList
    print "Could not retrieve mirrorlist %s error was\n%s" % (url, e)
  File "/usr/lib/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 155: ordinal not in range(128)


Please provide update to stable Fedora 11.

Comment 9 martin.bund 2010-01-03 12:13:37 UTC
(In reply to comment #7)
> fixed upstream  

@svidal: Where do I find the patch and how do I apply it?
I have the same problem as described in comment #6 (see the lines below).
Any help is apreciated, thanks in advance!

[root@mypc ~]# yum update yum
Geladene Plugins: dellsysidplugin2, kernel-module, refresh-packagekit
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 311, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 180, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 349, in doCommands
    self._getTs(needTsRemove)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 100, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 111, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 702, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 538, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 277, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 164, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 222, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1222, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1386, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1378, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1368, in _loadRepoXML
    return self._groupLoadRepoXML(text, ["primary"])
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1351, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1197, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 976, in _getFileRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 797, in _getFile
    result = self.grab.urlgrab(misc.to_utf8(relative), local,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 498, in <lambda>
    grab = property(lambda self: self._getgrab())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 493, in _getgrab
    self._setupGrab()
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 482, in _setupGrab
    self._grab = mgclass(self._grabfunc, self.urls,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 655, in <lambda>
    urls = property(fget=lambda self: self._geturls(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 652, in _geturls
    self._baseurlSetup()
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 606, in _baseurlSetup
    mirrorurls.extend(self._getMirrorList())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1625, in _getMirrorList
    print "Could not retrieve mirrorlist %s error was\n%s" % (url, e)
  File "/usr/lib/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 123: ordinal not in range(128)
[root@mypc ~]#

Comment 10 Tim Lauridsen 2010-01-03 15:49:16 UTC
http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=19007027602de8943edc8c82cf27f69c54c40269

It is included in the latest yum release 3.2.25

Comment 11 Tim Lauridsen 2010-01-03 15:52:27 UTC
*** Bug 551972 has been marked as a duplicate of this bug. ***

Comment 12 livelace 2011-08-03 14:57:28 UTC
[root@vm rhn-packages]# yum --version
3.2.29
  Installed: rpm-4.8.0-16.el6.x86_64 at 2011-06-19 12:00
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2011-03-09 06:32
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2011-03-09

  Installed: yum-3.2.29-17.el6.noarch at 2011-08-03 14:38
  Built    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> at 2011-04-28 17:43
  Committed: James Antill <james.antill@redhat.com> at 2011-04-28

#----------------------------------------------------------------

[root@vm rhn-packages]# yum update
Loaded plugins: refresh-packagekit, rhnplugin
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 274, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 129, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 432, in doCommands
    self._getTs(needTsRemove)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 99, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 110, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 882, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 668, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 260, in populateSack
    self.doSetup()
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 72, in doSetup
    self.ayum.plugins.run('prereposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 184, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/share/yum-plugins/rhnplugin.py", line 121, in prereposetup_hook
    str(e))
  File "/usr/share/rhn/up2date_client/up2dateErrors.py", line 177, in __repr__
    "The message was:\n") + self.errmsg
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)

Comment 13 Lukasz Wrzosek 2011-11-12 18:49:39 UTC
[lukasz]::[localhost]~
<*> LC_ALL=C yum search -C bash
Loaded plugins: langpacks, presto, refresh-packagekit


[Errno 13] Permission denied: '/var/cache/yum/i386/16/fedora/877fa92998aaf980f39dd4034e7bf68c223bd4741e43d25de94ebf4d1c38682f-comps-f16.xml'
[lukasz]::[localhost]~
<*> LC_ALL=pl_PL.UTF-8 yum search -C bash
Wczytane wtyczki: langpacks, presto, refresh-packagekit
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 149, in main
    return exIOError(e)
  File "/usr/share/yum-cli/yummain.py", line 51, in exIOError
    logger.critical(_('\n\n%s') % exception2msg(e))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc4 in position 20: ordinal not in range(128)
[lukasz]::[localhost]~
<*> yum --version
3.4.3
  Zainstalowane: rpm-4.9.1.2-1.fc16.i686 o 2011-11-11 18:57
  Zbudowane    : Fedora Project o 2011-09-29 13:58
  Wysłane: Panu Matilainen <pmatilai@redhat.com> o 2011-09-29

  Zainstalowane: yum-3.4.3-5.fc16.noarch o 2011-11-11 18:57
  Zbudowane    : Fedora Project o 2011-09-26 09:17
  Wysłane: Richard W.M. Jones <rjones@redhat.com> o 2011-09-26

Comment 14 Milan Bouchet-Valat 2012-01-01 14:52:27 UTC
Same here when trying to remove a kernel package (from Rawhide, while I'm on F16):

# yum remove kernel-3.2.0-0.rc7.git3.1.fc17.x86_64
[...]
Test de la transaction en cours
ERREUR lors de la vérification de la transaction avec les dépendances :
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 223, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 563, in doTransaction
    print to_utf8(msg)
  File "/usr/lib64/python2.7/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 45: ordinal not in range(128)