Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5022

Summary: Netscape not getting fonts from xfs for Java.
Product: [Retired] Red Hat Linux Reporter: zoratu
Component: netscapeAssignee: David Lawrence <dkl>
Status: CLOSED DUPLICATE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-09 14:23:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description zoratu 1999-09-09 13:36:16 UTC
This bug has appeared on sparc and x86 for me.

The default install of 6.0 with Netscape, trying to use Java
causes Netscape to die a horrible death (bus error).

It seems that it is croaking in "GetFontList", and by
reconfiguring xfs to look at all the available fonts that
are installed (including the ones in
/var/share/fonts/default) it fixes it. It shouldn't die
getting a list of fonts. I suspect that it tried to get a
list of specific fonts and couldn't get any, and got a NULL
list back, and it croaked becaues it doesn't check for
NULLs. But that is just my suspicion.

Comment 1 Bill Nottingham 1999-09-09 14:23:59 UTC
*** This bug has been marked as a duplicate of 2711 ***