Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 5019

Summary: Upgrade Fails on a 6.0
Product: [Retired] Red Hat Linux Reporter: jharris
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-06 15:13:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jharris 1999-09-09 11:06:01 UTC
Using Lorax to upgrade a 6.0 system cause a system
hang/crash. In the second stage of the install the system
hangs while searching installed packages.  From the script
output a permision error is seen while trying to call
makeinode in of the python scripts. So it appears that the
script is attempting to write something where it can't

Comment 1 jharris 1999-09-13 04:31:59 UTC
Some more debug info I have found. The error output from the install
is
File "/usr/lib/python1.5/site-packages/isys.py" Line 63 in
makeDevinode
return _isys.mkdevinode(name,fn)
SystemError (2,No such file or directory);

The whole calling chain was displayed.. but I thought was the relevent
portion.

Comment 2 Jay Turner 1999-12-06 15:13:59 UTC
By any chance do you have /tmp symlinked to somewhere?  There is a problem in
the installer (which is really hard to workaround unfortunately) that the
installer is not able to follow absolute symlinks.  It is fine with relative
symlinks, so if you have an absolute symlink, just change it to be a relative
one and your install should work fine.  I am marking this bug a duplicate of
#6141.  Please reopen if the symlink change does not resolve the problem.

*** This bug has been marked as a duplicate of 6141 ***