Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 494541

Summary: [KVM] E1000 PXE boot fails with "No IP address"
Product: [Fedora] Fedora Reporter: Kari Hautio <kari.hautio>
Component: etherbootAssignee: Eduardo Habkost <ehabkost>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 11CC: dwmw2, dyoung, ehabkost, gcosta, markmc, mgregg, virt-maint, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-23 11:57:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 188611    
Attachments:
Description Flags
VM screenshot none

Description Kari Hautio 2009-04-07 12:25:02 UTC
Created attachment 338494 [details]
VM screenshot

Description of problem: 


Version-Release number of selected component (if applicable):

qemu-0.10-5.fc11.x86_64
libvirt-0.6.2-1.fc11.x86_64

$ uname -r
2.6.29.1-46.fc11.x86_64

How reproducible:

always

Steps to Reproduce:
1. Create new virtual machine with virt-manager 
2. change network interface to e1000 and set boot source to PXE
3. start machine
  
Actual results:

PXE fails to acquire IP address

Expected results:

PXE is able to get IP address (and fails as TFTP filename is not set)

Additional info:

VM screenshot attached.

Comment 1 Mark McLoughlin 2009-04-09 15:38:23 UTC
Looks like it's an issue with the e1000 PXE ROM from etherboot

Does it work with rtl8139 or virtio?

Comment 2 Kari Hautio 2009-04-09 16:46:21 UTC
Forgot to mention that rtl and pcnet work (did not test virtio).

Comment 3 Mark McLoughlin 2009-04-19 14:55:36 UTC
*** Bug 495970 has been marked as a duplicate of this bug. ***

Comment 4 Mark McLoughlin 2009-05-11 11:25:02 UTC
Could you try and rebuild etherboot with this change:

--- etherboot-5.4.4/src/Config.old	2009-05-11 12:23:47.000000000 +0100
+++ etherboot-5.4.4/src/Config	2009-05-11 12:23:59.000000000 +0100
@@ -469,7 +469,7 @@
 # (Requires TFTP protocol support)
 CFLAGS+=	-DPXE_IMAGE -DPXE_EXPORT
 # Etherboot stricter as a PXE network protocol ROM
-# CFLAGS+=	-DPXE_DHCP_STRICT
+CFLAGS+=	-DPXE_DHCP_STRICT
 
 # Support for PXE emulation. Works only with FreeBSD to load the kernel
 # via pxeboot, use only with DOWNLOAD_PROTO_NFS



Eduardo suggests it may help

Comment 5 Eduardo Habkost 2009-05-11 19:33:39 UTC
Tip: using rom-o-matic.net (http://rom-o-matic.net/etherboot/etherboot-5.4.4/contrib/rom-o-matic/) may be useful to play with Etherboot build options without the need to build the images locally.

Comment 6 Kari Hautio 2009-05-14 07:30:13 UTC
Etherboot compiled with PXE_DHCP_STRICT works.

Tested with rom-o-matic generated etherboot-5.4.4 for 82540em, all defaults except set PXE_DHCP_STRICT.

Comment 7 Mark McLoughlin 2009-05-21 20:49:02 UTC
Eduardo: should we switch to PXE_DHCP_STRICT, or is that likely to break other people's setups?

Comment 8 Eduardo Habkost 2009-05-21 20:59:02 UTC
(In reply to comment #7)
> Eduardo: should we switch to PXE_DHCP_STRICT, or is that likely to break other
> people's setups?  

I have seen many cases of PXE not working because PXE_DHCP_STRICT is disabled, but no cases yet of systems breaking because of PXE_DHCP_STRICT. I recommend we enable it.

Comment 9 Mark McLoughlin 2009-05-25 13:40:13 UTC
Okay, I'm pushing this to updates-testing:

* Mon May 25 2009 Mark McLoughlin <markmc@redhat.com> - 5.4.4-14
- Enable PXE_DHCP_STRICT to fix PXE boot failures (bug #494541)

Please test and add a +/- comment to the update

Comment 10 Fedora Update System 2009-05-25 13:47:20 UTC
etherboot-5.4.4-14.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/etherboot-5.4.4-14.fc11

Comment 11 Fedora Update System 2009-05-26 07:56:06 UTC
etherboot-5.4.4-14.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update etherboot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5506

Comment 12 Kari Hautio 2009-05-26 08:15:21 UTC
etherboot-5.4.4-14.fc11 still presents the problem.

Comment 13 Bug Zapper 2009-06-09 13:24:39 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 14 Fedora Update System 2009-06-19 16:46:41 UTC
etherboot-5.4.4-15.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/etherboot-5.4.4-15.fc11

Comment 15 Mark McLoughlin 2009-06-23 11:57:41 UTC
Okay, I've tracked down the real cause of this in bug #507391, so marking as a dup of that

*** This bug has been marked as a duplicate of bug 507391 ***